HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jun 05, 2012, 06:34 PM
Registered User
Joined Dec 2011
36 Posts
Discussion
Should motors spin when armed and throttle stick down?

I was testing my multiwii and when I armed the motors, they did not spin until i moved the throttle stick up slightly. This was before I calibrated the ESC's. I have now calibrated the ESC's and as soon as I arm the motors, they begin to spin. Is this the correct operation?

FYI...

minthrottle=1150
mincommand=1000
maxthrottle=1850

Thanks!
SplitFire is offline Find More Posts by SplitFire
Reply With Quote
Sign up now
to remove ads between posts
Old Jun 05, 2012, 06:47 PM
Registered User
United States, NV, North Las Vegas
Joined Sep 2009
1,075 Posts
Yes it's normal in MW, myself I don't like this feature but I do understand the value. if you want the motors to not spin up as soon as you arm, open the MW sketch> config.h tab and look for and uncomment MOTOR_ STOP it's down near the bottom of the config.h page. once this is done the motors will not spin up until you apply throttle.


Edit: go with FullmoonCat's post... he went all out with the fancy code paste
shultz is offline Find More Posts by shultz
Last edited by shultz; Jun 05, 2012 at 06:57 PM.
Reply With Quote
Old Jun 05, 2012, 06:48 PM
Rank Amatuer
FullmoonCat's Avatar
United States, ID, Boise
Joined Dec 2011
506 Posts
There's also this setting:

Code:
/********************************************************************/
/****           motor, servo and other presets                   ****/
/********************************************************************/
/* motors will not spin when the throttle command is in low position
   this is an alternative method to stop immediately the motors */
#define MOTOR_STOP
If that's not uncommented, the blades will spin at lowest position.

Otherwise, you could try changing the mincommand to 900.

EDIT: Ninja'd!
FullmoonCat is offline Find More Posts by FullmoonCat
Reply With Quote
Old Jun 05, 2012, 07:00 PM
Registered User
Joined Dec 2011
36 Posts
Thanks a lot! I just got a little confused since they spun BEFORE calibrating the ESC's and then after calibration, they didn't spin up. I would have looked through the code, but since I didn't make any code changes and had different results, I wasn't sure what was going on
SplitFire is offline Find More Posts by SplitFire
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Xieada 9958 spins to left when throttle is increased danagelh Mini Helis 9 Aug 15, 2013 12:17 PM
Discussion Great Wall Xieda 9958 spins rapidly to the left when I give it throttle the desolate one Micro Helis 4 May 09, 2012 01:44 AM
Discussion Down With The 10% Throttle Cut and High Arm Northstar32 Multirotor Talk 3 May 07, 2012 05:59 AM
Discussion mCX2, upper blades not spinning down as they should... ChopperBopper Coaxial Helicopters 0 Jan 10, 2012 12:51 AM
Discussion Can't get my brushless motor to spin, it beeps when I arm it Wolygon Power Systems 14 May 21, 2011 10:37 AM