HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 24, 2015, 05:29 PM
Registered User
Joined Jan 2015
8 Posts
Discussion
Ares Ethos QX 130 not responding

My quad for some reason will just stop. I throttle up and it starts to take off and then nothing. I can't figure out what is causing this. Any help would be greatly appreciated!
JBarg42 is offline Find More Posts by JBarg42
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 27, 2015, 12:21 AM
Registered User
Joined Jan 2015
1 Posts
I had this problem just yesterday. It was right after I had connected the video camera. It turned out that I had a defective camera. If I disconnected the camera the aircraft flew just fine. I went back to the store, exchanged the camera and now it flies great with and without the camera.

The funny thing is that the issue happened right at the time an Air force UH-1 flew over. I'm a private pilot and a former Cobra Crew Chief. Even with that background for about 5 minutes I entertained the idea that the Huey was the cause of my Ares Ethos losing power.

I know, silly... unless the UH-1 was jamming my signal because it determined that I was a threat. ;-)
Voodoobones is offline Find More Posts by Voodoobones
Reply With Quote
Old Jan 28, 2015, 12:17 AM
Registered User
guitrdead's Avatar
Joined Dec 2014
8 Posts
Quote:
Originally Posted by JBarg42 View Post
My quad for some reason will just stop. I throttle up and it starts to take off and then nothing. I can't figure out what is causing this. Any help would be greatly appreciated!
I had to have my board replaced yesterday due to the same issue. Are you getting a blinking red light and will it not bind to the radio anymore?
guitrdead is online now Find More Posts by guitrdead
Reply With Quote
Old Jan 31, 2015, 06:25 PM
Registered User
Joined Jan 2015
8 Posts
Quote:
Originally Posted by guitrdead View Post
I had to have my board replaced yesterday due to the same issue. Are you getting a blinking red light and will it not bind to the radio anymore?
Yes, I am getting a flashing light and I am not able to bind it w/ the TX.

Quote:
Originally Posted by Voodoobones View Post
It was right after I had connected the video camera. It turned out that I had a defective camera. If I disconnected the camera the aircraft flew just fine. I went back to the store, exchanged the camera and now it flies great with and without the camera.
This worked for me as well! It connected and flew just great after disconnecting the camera. Funny thing is though, I plugged it back in and it is still working. It seems to be a temperamental little machine. Haha

Thank you both for your help! I very much appreciate it!
JBarg42 is offline Find More Posts by JBarg42
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
News New! Ares Ethos QX 130 Jason Cole Multirotor Talk 621 Feb 12, 2015 08:11 PM
Discussion Ares Ethos QX 130 Brushed to Brushless Mod arrogantartistpr Mini Multirotors 13 Jan 18, 2015 05:03 PM
Discussion Ares Ethos QX 130 questions Mcook929 Multirotor Talk 3 Dec 28, 2014 08:12 PM
Discussion Ares Ethos QX 130 questions Mcook929 Beginner Training Area (Heli-Electric) 2 Dec 28, 2014 07:12 PM
Discussion Ares Ethos qx 130 MPH1 Mini Multirotors 12 Jul 27, 2014 07:44 AM