HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old May 26, 2014, 02:49 AM
MB-Commander
Minibichus's Avatar
Joined Feb 2008
2,478 Posts
Alert
eLogger V3 fried and took all the accesories along with it!!

As tittle reads:

About a week or so ago I was flying my scale helicopter when we smelled burnt silicon fumes coming from somewhere inside it. Sure enough, I landed it and found out it was the EagleTree which was burnt to the core. Glad I landed it, because it would've not been nice to crash due to no power anywhere.

So, didn't thought much of it (since it is old and I wanted to replace it anyways due to the USB issue) A couple of days later I got a new eLogger V4 and I plugged the OSD Pro into the eLogger V4 to reconfigure everything and to my dismay it doesn't work: The eLogger not only killed itself, it took along the OSD Pro. So, okay fine, I go ahead and order another OSD Pro and get a request from Eagletree to RMA the OSD Pro. I haven't sent it yet because I was waiting for the new OSD Pro to show up to confirm is the OSD Pro what is damaged and not the new eLogger V4.

OSD Pro arrives Saturday and I get it working right away. Load the settings back onto it and when I go to hook it up to the fuselage where the other I2C sensors are, the OSD Pro freezes; I unplug it from the guardian/altimeter I2C plug and it works again.

Sure enough, I quickly removed the altimeter and the guardian from their location inside the fuselage and proceeded to test them with the eLogger V4 plugged directly to the USB... no dice. Neither one of these work!! The stupid eLogger V3 not only took down my OSD Pro, it also took the Guardian artificial horizon and the barometric altimeter V4.

The GPS V3 looks like it might've survived since it still works and reads what appears to be correct data.

I also have a couple of older eLogger V3s on my other helicopters and none these accesories work on the V3s either, the older V3 blinky LEDs stop blinking once I plug any of those components into the I2C bus. (same with the new V4)

So, let me get this straight: One component fails, all others burn out too? What gives? Is this on purpose? I mean, c'mon these components had hundreds of flights on them and were properly secured (bolted down inside a scale fuselage where I haven't messed with them for several years and magically they all burn out?

Now I have to shell even more cash to replace the whole Eagletree stuff?
65 for the eLogger V4
84 for the replacement OSD Pro
59 for a replacement Guardian Expander
43 for a replacement Altimeter Microsensor V4
251 dollars!!

SO BEWARE IF YOU ARE THINKING ABOUT BUYING EAGLETREE!, because it seems that if one burns, all the other ones will burn too!!, just to ensure you have to buy everything again.

And give me a break: 251 dollars, and no magnetic compass!!!??? WTH??
Minibichus is offline Find More Posts by Minibichus
Reply With Quote
Sign up now
to remove ads between posts
Old May 26, 2014, 08:59 AM
JohnET's Avatar
United States, NC, Charlotte
Joined Apr 2013
474 Posts
Hello,

I can assure you that our devices are not designed to intentionally damage other devices in order for you to have to buy new ones. It is possible a catastrophic failure of a device can cause a short or power surge to the connected components but it would be a very rare occurrence.

Can you update your currently open support ticket with the additional info about the damaged sensors? We will get it sorted for you.

Regards, John
JohnET is offline Find More Posts by JohnET
Site Sponsor
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold Eagletree OSD Pro Pkg with eLogger v3, OSD Pro, and GPS peekay331 FPV Equipment (FS/W) 2 Jan 28, 2014 11:32 AM
For Sale EagleTree Elogger V3 with Free RPM sensor mmalik4 FPV Equipment (FS/W) 0 Jan 07, 2014 03:20 PM
Question Help with elogger V3 and GPS expander V3 talkthetorque Eagle Tree Systems 6 Jul 28, 2012 10:26 AM
Discussion Airspeed V3 doesn't work with eLogger V3 tskloss Eagle Tree Systems 1 Dec 27, 2010 01:56 AM
Discussion Problems with 5Hz GPS Expander V3 and eLogger V3! Geni Eagle Tree Systems 7 Aug 14, 2008 01:08 AM