HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 13, 2013, 03:57 AM
Registered User
Joined Apr 2013
1 Posts
Whoops!
Trouble with low rpm

Hello everyone
I just bought the walkera v120d02s and i were going to try to fly it for the first time. It spun up the first time but later when i tried it. It didn't spin up like it did the first time. It was "hacking" on the low rpm and i didn't get it to spin up to the usual rpm. I still have the problem so what can be wrong?
Thanks for the responds and happy flying
R4MBO is offline Find More Posts by R4MBO
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 14, 2013, 03:08 PM
Never trust laughing dolphins
Joined Feb 2011
2,085 Posts
Quote:
Originally Posted by R4MBO View Post
Hello everyone
I just bought the walkera v120d02s and i were going to try to fly it for the first time. It spun up the first time but later when i tried it. It didn't spin up like it did the first time. It was "hacking" on the low rpm and i didn't get it to spin up to the usual rpm. I still have the problem so what can be wrong?
Thanks for the responds and happy flying
Dead battery? Did you charge it properly?

Other than that check the blades for being bend too much. They might drag more instead of giving lift or something along those lines.
PHMX is offline Find More Posts by PHMX
Reply With Quote
Old Jun 28, 2013, 06:19 AM
High VulTAge
Joined Apr 2013
260 Posts
Quote:
Originally Posted by R4MBO View Post
Hello everyone
I just bought the walkera v120d02s and i were going to try to fly it for the first time. It spun up the first time but later when i tried it. It didn't spin up like it did the first time. It was "hacking" on the low rpm and i didn't get it to spin up to the usual rpm. I still have the problem so what can be wrong?
Thanks for the responds and happy flying
spin the rotor with your fingers, does it spin freely and a couple times around? or does it stop instantly or at a certain point? If the rotor and tail spin smooth and freely,.. I would say, u may have a loose wire, or connection. It did spin up good the first time? Did you happen to crash it? I would check the batt connectors as those little white ones can burn up, or I've also seen the wires almost fall out of them, and need soldering,.. I recommend replacing them all with Micro Deans. Also check the motor connectors. Mine get pretty warm, I'm thinking of eliminating the motor plug, and solder direct. Your pinion could be too tight. If you tighten any of the tail holding or tail servo screws onto the tailshaft too tight,.. it can bind up the tail shaft inside of it. If you crashed and the carbon fiber broke,. it can also bind it up. Start there.
Vultage is offline Find More Posts by Vultage
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Outrunner with no low end RPM bigheaded5 Multirotor Electronics 0 Apr 03, 2013 05:09 AM
Discussion Having trouble with my new Turnigy Accu 6 starzak Batteries and Chargers 7 Mar 30, 2013 03:51 PM
Discussion Trouble with a 48" wing - tip stall or low power? airRX Flying Wings 8 Aug 25, 2009 11:04 PM
Discussion Probem with 'motor" at low RPM gspencer Micro Helis 10 Dec 26, 2008 03:26 PM
Big prop-low rpm or small prop-high rpm Ninjak2k Power Systems 10 Feb 13, 2002 04:28 PM