HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old May 03, 2012, 10:21 AM
Registered User
sjgusmc21's Avatar
Lorton, Va
Joined May 2004
390 Posts
Discussion
Need Help With Fried FatShark TX

Need some help Gurus. OK, so I purchased the 5.8 Fatshark Predators. The first time I hooked it up, all was well. The second time I hooked it up, I fried the TX (not paying attention). So I ordered a 5.8 200 mhz from FoxPro....doesn't work, however, works if I connect the receiver into the the Fatshark goggles. But alone, the Fatshark doesn't work (blurred image). Then I read that Immersion RC 600 5.8 works with Fatshark and FoxPro does not. So I ordered the IMRC 600....and nope doesn't work. So now, I just ordered the FatShark 100 TX, and hopefully it will work again. My goal with this system is to use it with my Trex 600 and 800 AP helis for the camera operator, so I was hoping to get a little better range out of it then the standard 5.8 100 FS TX. At this point, I don't know if my original camera works or not...might have fried it as well, but I ordered a second one (different) and it works with the FoxPro TX.

http://www.foxtechfpv.com/cm210-high...era-p-294.html

I also ordered one of these...thinking I might get better resolution from it...

http://www.foxtechfpv.com/fh-32-hq1-...tsc-p-238.html

However, I can't figure out how to connect it. Anyone know how to connect this camera? No instructions.

I appreciate any and all suggestions. Take care.
sjgusmc21 is offline Find More Posts by sjgusmc21
Reply With Quote
Sign up now
to remove ads between posts
Old May 03, 2012, 06:10 PM
Registered User
sjgusmc21's Avatar
Lorton, Va
Joined May 2004
390 Posts
Anyone?
sjgusmc21 is offline Find More Posts by sjgusmc21
Last edited by sjgusmc21; May 04, 2012 at 09:48 AM.
Reply With Quote
Old May 04, 2012, 09:49 AM
Registered User
sjgusmc21's Avatar
Lorton, Va
Joined May 2004
390 Posts
Buehler????
sjgusmc21 is offline Find More Posts by sjgusmc21
Reply With Quote
Old May 04, 2012, 11:44 AM
Registered User
Joined Oct 2007
785 Posts
The IMRC 600 should work just fine with the built in RX in the predators... You're doing something wrong there.

Have you set the channels to match?

As for cam same as any other. Feed the positive cable with the required voltage (12v in this case - 3S lipo would do), connect ground and then take the video out to your vTX.
rusty_y2k2 is offline Find More Posts by rusty_y2k2
Reply With Quote
Old May 04, 2012, 01:13 PM
Registered User
sjgusmc21's Avatar
Lorton, Va
Joined May 2004
390 Posts
Thanks Rusty. I will check the channels. Getting really frustrated with this.....I appreciate your help.
sjgusmc21 is offline Find More Posts by sjgusmc21
Reply With Quote
Old May 10, 2012, 01:54 PM
Registered User
sjgusmc21's Avatar
Lorton, Va
Joined May 2004
390 Posts
Quote:
Originally Posted by rusty_y2k2 View Post
The IMRC 600 should work just fine with the built in RX in the predators... You're doing something wrong there.

Have you set the channels to match?

As for cam same as any other. Feed the positive cable with the required voltage (12v in this case - 3S lipo would do), connect ground and then take the video out to your vTX.
Ok, so I even replaced the 5.8 unit in the head set, nothing. I have tried every channel possible, both with a new FS 5.8 transmitter and the IMRC 600, following the instructions. Nothing. Checked every channel. As I said, I can get great reception if using a external 305 receiver plugged into the headset and a different 5.8 transmitter. I am so freak'n confused...so simple yet......
sjgusmc21 is offline Find More Posts by sjgusmc21
Reply With Quote
Old May 10, 2012, 02:14 PM
Registered User
Joined Oct 2007
785 Posts
Perhaps it's overly patronizing, but you haven't flicked the receiver switch to off have you?

Small black switch on underside - one position uses internal RX, other external av in.
rusty_y2k2 is offline Find More Posts by rusty_y2k2
Reply With Quote
Old May 11, 2012, 06:55 AM
Registered User
sjgusmc21's Avatar
Lorton, Va
Joined May 2004
390 Posts
Quote:
Originally Posted by rusty_y2k2 View Post
Perhaps it's overly patronizing, but you haven't flicked the receiver switch to off have you?

Small black switch on underside - one position uses internal RX, other external av in.
No feelings hurt here Rusty. Yes, I have turned the switch on and off. This thing is just really pissing me off. So, Sequence of events.

1. Received FS plugged in OEM worked great.
2. Stupid attack, fried TX and Camera by plugging battery directly into it.
3. Ordered 5.8 TX and RX from HK...worked, but only when jacked into Head Set and RX off on google.
4. Ordered 5.8 IMRC 600, does not work with Headset.
5. Ordered 5.8 FS replacement TX. EXACT SAME AS OEM. Does not work.
6. Ordered new camera. Tried switching Pos/Grnd.....only works when setup in number 3.
7. Ordered new 5.8 FS RX for head set. Same exact issue.
8. Have tried all possible channel combos. No go.



Done throwing money at it...about to go on Fleabay.......
sjgusmc21 is offline Find More Posts by sjgusmc21
Reply With Quote
Old May 11, 2012, 07:09 AM
Registered User
Joined Oct 2007
785 Posts
You tried emailing fatshark?
rusty_y2k2 is offline Find More Posts by rusty_y2k2
Reply With Quote
Old May 11, 2012, 07:55 AM
Registered User
sjgusmc21's Avatar
Lorton, Va
Joined May 2004
390 Posts
No not yet. Just had a 8 pound baby girl so trying to get things in when I can.
sjgusmc21 is offline Find More Posts by sjgusmc21
Reply With Quote
Old May 11, 2012, 08:58 AM
Registered User
Joined Oct 2007
785 Posts
Congrats!

Try emailing them for support. Perhaps they can help.
rusty_y2k2 is offline Find More Posts by rusty_y2k2
Reply With Quote
Old May 11, 2012, 06:56 PM
Registered User
sjgusmc21's Avatar
Lorton, Va
Joined May 2004
390 Posts
Will do.
sjgusmc21 is offline Find More Posts by sjgusmc21
Reply With Quote
Old May 15, 2012, 08:03 AM
Registered User
sjgusmc21's Avatar
Lorton, Va
Joined May 2004
390 Posts
Wow, actually had time between feedings (8 day old, not myself) and dropped Fatshark a email. Can't believe how fast Greg responded! So far, I am VERY IMPRESSED! Rusty, thanks for the suggestion.
sjgusmc21 is offline Find More Posts by sjgusmc21
Reply With Quote
Old May 25, 2012, 07:14 AM
Registered User
fatshark's Avatar
Shenzhen, China
Joined May 2007
403 Posts
Quote:
Originally Posted by sjgusmc21 View Post
No feelings hurt here Rusty. Yes, I have turned the switch on and off. This thing is just really pissing me off. So, Sequence of events.

1. Received FS plugged in OEM worked great.
2. Stupid attack, fried TX and Camera by plugging battery directly into it.
3. Ordered 5.8 TX and RX from HK...worked, but only when jacked into Head Set and RX off on google.
4. Ordered 5.8 IMRC 600, does not work with Headset.
5. Ordered 5.8 FS replacement TX. EXACT SAME AS OEM. Does not work.
6. Ordered new camera. Tried switching Pos/Grnd.....only works when setup in number 3.
7. Ordered new 5.8 FS RX for head set. Same exact issue.
8. Have tried all possible channel combos. No go.



Done throwing money at it...about to go on Fleabay.......
sjgusmc,
We received your equipment back and have done testing. The 100mW TX outputted 150mW, the 600mW outputted 600mW. We put your headset in with our production headset range tests and receiver sensitivity was normal.
I tested with our standard 5V cameras and image was perfect. We plugged in your supplied no-name brand camera and got no image.
Unfortunately the only problem you had was either an incorrectly wired camera or maybe its 12V and you are attempting to power it off the TX 5V supply. Since I know nothing about the camera I didn't attempt to wire it up correctly.
Seems the only item you need to post on eBay is the camera, keep the Fat Shark gear.

Fat Shark
fatshark is offline Find More Posts by fatshark
Reply With Quote
Old May 25, 2012, 07:34 AM
Registered User
Joined Oct 2007
785 Posts
Nice job Greg... I love to see good customer service.

Now just hurry up and get your new products out
rusty_y2k2 is offline Find More Posts by rusty_y2k2
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Fatsharks Fried R polarity, JudoLisa FPV Talk 11 Mar 21, 2012 10:20 PM
Discussion Help needed on purchase of FPV TX/RX setup with my Spektrum DX8. Which MHZ to use jasper7821 FPV Talk 14 Feb 14, 2012 07:08 PM
Discussion Help in Chicago needed with testing mCX2 and TX dnknitro USA - District VI 2 Feb 02, 2012 01:48 PM
Help! Need help with turnigy 9x tx and hk 401b gyro Hot_Wheels Mini Helis 4 Jan 10, 2012 09:03 PM
Help! Need help with turnigy 9x tx and hk 401b gyro Hot_Wheels Electric Heli Talk 0 Jan 09, 2012 10:13 PM