SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Jul 28, 2011, 07:39 AM
Registered User
daveh's Avatar
Northwest Ohio
Joined Apr 2001
162 Posts
Discussion
Ace Digipulse won't work

My Ace Digipulse multi charger with 6 charging ports doesn't work ! Been using for my nimh receiver packs for a few years, and love this thing....
I plug it in and the "power light" -- the one right over "solid=hours, and just to the left of the digital readout -- this light goes on solid, but nothing else happens. I plug in a battery, and nothing... I hit the "program" button and nothing. I have hit the reset button with a paper clip and nothing....

Anyone have any ideas or experience with this? Any input please... Could it be the wall wart has gone bad? (its the OEM original) .

Thank you!
Dave
daveh is offline Find More Posts by daveh
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 28, 2011, 10:02 AM
Registered User
pilotpete2's Avatar
The Northeast Kingdom, Vermont
Joined Jun 2004
5,246 Posts
Hi Dave,
You can check the wall wart if you have a meter, it should read 24Vac (rectifiers are in main unit).
If you have an 9V battery installed to hold settings during a power failure, remove it, if it's real low on voltage it could be a problem. As I remember, the 9V memory battery is behind the right end plate of the case.
Without the battery installed, leave the power plug from the wall wart off for a minute, then see if the display shows a count up of 1 to 0, followed by the program light blinking once. I hope you get it working. I still use mine for charging my transmitter, though I don't use Ni cells anymore in my gas and glow models, all now on 2S A123 cells.
Best of luck,
Pete

P.S. I have my unit setup with outputs 5 & 6 permanently jumper-ed for charging at up to 280mA for to days Nimh packs. They used to sell a "Y" cable that did the same thing
pilotpete2 is offline Find More Posts by pilotpete2
Reply With Quote
Old Jul 28, 2011, 11:33 AM
Registered User
daveh's Avatar
Northwest Ohio
Joined Apr 2001
162 Posts
Thanks PilotPete, tested the ac adaptor output, and its reading almost "0". So maybe my ac adaptor is shot. On the adaptor, it says "Temperature Fuse Included" -- would this be inside the adaptor, and is this replaceable?? and how would one go about opening up the adaptor??? As a side note, when the charger is plugged in, there is not any digital numerical readout... only the "power" red button goes on...

Thanks
Dave
daveh is offline Find More Posts by daveh
Reply With Quote
Old Jul 28, 2011, 11:36 AM
Registered User
daveh's Avatar
Northwest Ohio
Joined Apr 2001
162 Posts
Also, anyone know somewhere I can purchase an ac adaptor -- on the back it says:
Model BT2038
Input: 110vac 60hz 40w
Output: 24vac 1.8 a

Thanks!
Dave
daveh is offline Find More Posts by daveh
Reply With Quote
Old Jul 28, 2011, 05:19 PM
Registered User
daveh's Avatar
Northwest Ohio
Joined Apr 2001
162 Posts
Rick,

Thanks for the great links, I will buy one of these and give it a go, I think that will do the trick! Thanks again, and Pilot Pete too!
Daveh
daveh is offline Find More Posts by daveh
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Wanted Ace Super DigiPulse Charger futura127 Aircraft - Electric - Batteries & Chargers (FS/W) 0 Jul 17, 2011 09:21 AM
Discussion Help! New heli won't work. United_matt Beginner Training Area (Heli-Electric) 7 May 04, 2011 11:38 AM
Help! Brushless system won't work! mykanic Off-road Cars 3 Apr 17, 2011 11:06 AM
Discussion Ace Super Digipulse Charger Manual mundo330 Batteries and Chargers 0 Mar 05, 2011 08:54 PM
Discussion ESC Won't Arm - CC BEC Won't Work With Stock ESC??? annarelli Electric Heli Talk 6 Apr 14, 2010 02:56 PM