SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Sep 07, 2012, 06:30 PM
Registered User
Bay Village, OH
Joined Dec 2009
24 Posts
Discussion
Charging A123 with the 10s

I am new to modern chargers (you know, the chargers for Nicad and NiMH batteries) and am looking for some specific information about my newer setups.

I have the 10s charger and am using it to feed a bunch of Electrodynamics A123 batteries that I use for flight and ignition packs in airplanes. I used the computer software to setup presets. in one airplane I have a single flight pack and a single ignition pack, I set the preset to setup a program to charge both at the same time and it works. I have to use the plug blocker.

In another airplane I have two large 2s2p A123 4600mah packs and a single ignition pack that is a 2s1p. I setup two separate programs. I cant seem to figure out how to connect my banana plugs and balance plugs to charge the 2s2p flight packs. I think it should charge through the balance plugs alone...but I cant get the 2s2p flight packs using the plug blocker. Also, I am charging the packs at 3.5A...electrodynamics says to stay at or below 4A with their charging connectors.

I know this has to be simple I just want to figure it out. Please help! =)

Thanks, Chris
cmoore806 is offline Find More Posts by cmoore806
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 08, 2012, 12:12 PM
President, FMA, Inc.
Tim Marks's Avatar
Joined Mar 2008
1,059 Posts
Quote:
Originally Posted by cmoore806 View Post
I am new to modern chargers (you know, the chargers for Nicad and NiMH batteries) and am looking for some specific information about my newer setups.

I have the 10s charger and am using it to feed a bunch of Electrodynamics A123 batteries that I use for flight and ignition packs in airplanes. I used the computer software to setup presets. in one airplane I have a single flight pack and a single ignition pack, I set the preset to setup a program to charge both at the same time and it works. I have to use the plug blocker.

In another airplane I have two large 2s2p A123 4600mah packs and a single ignition pack that is a 2s1p. I setup two separate programs. I cant seem to figure out how to connect my banana plugs and balance plugs to charge the 2s2p flight packs. I think it should charge through the balance plugs alone...but I cant get the 2s2p flight packs using the plug blocker. Also, I am charging the packs at 3.5A...electrodynamics says to stay at or below 4A with their charging connectors.

I know this has to be simple I just want to figure it out. Please help! =)

Thanks, Chris
Hi:

Having a little trouble understanding your issue. Sorry. You can charge by connecting both the balance connectors and the main pack wires at the same time. Or you can charge by connecting only the balance connectors and then inserting the plug blocker. We term the latter method balance-wire or node-only charging. When balance-wire only charging, the 10s reduces the charge current automatically to a maximum of 4A.

Are you having trouble physically making all the connections required, or are you getting some kind of safey code, or what? Perhaps you could illustrate your issues by uploading a photo or two???

Tim Marks
Tim Marks is offline Find More Posts by Tim Marks
Reply With Quote
Old Sep 08, 2012, 06:52 PM
Registered User
Bay Village, OH
Joined Dec 2009
24 Posts
Im sorry for being unclear....really. I just came off working two weeks of nights so my mind isnt so sharp I think =).

I tried plugging in with the plugs and the balance plugs but I get an error. I tried with the plug blocker and the balance plugs and also get an error. I am charging them through the switch charge jack.
cmoore806 is offline Find More Posts by cmoore806
Reply With Quote
Old Sep 08, 2012, 08:19 PM
President, FMA, Inc.
Tim Marks's Avatar
Joined Mar 2008
1,059 Posts
Quote:
Originally Posted by cmoore806 View Post
Im sorry for being unclear....really. I just came off working two weeks of nights so my mind isnt so sharp I think =).

I tried plugging in with the plugs and the balance plugs but I get an error. I tried with the plug blocker and the balance plugs and also get an error. I am charging them through the switch charge jack.
Hi:

What errors are you getting? A photo of how you have things connected would still be helpful. Are you trying to charge 2 batteries at a time, or just one? Are you using any adapters? Also, have you tried disconnecting from the switch? Are there any diodes in the setup that could cause issues?

If you continue to have problems, you may want to contact Howard in customer service:

howard@fmadirect.com

or 301-829-5533

Tim Marks
Tim Marks is offline Find More Posts by Tim Marks
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion life / a123 charging weirdness with hyperion EOS charger ? aquaanox Batteries and Chargers 5 Jul 21, 2012 05:45 PM
Discussion FMA 10S "storage charge" for A123's..... JuanRodriguez Batteries and Chargers 2 Nov 04, 2009 08:25 PM
Discussion Charging A123 10S with the Astro 109 and 123 chip Martin Irvine Batteries and Chargers 8 Aug 17, 2009 06:43 PM
Discussion Astrofight 109 has problem charging 10s A123's with the new upgrade chip kfong Batteries and Chargers 19 Nov 19, 2008 10:16 AM
Discussion Charging 10s A123 cells w/ 2 chargers Doug101 Batteries and Chargers 7 Jun 25, 2007 04:48 PM