HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 13, 2012, 05:00 PM
There's magic in those wings !
khaled_abobakr's Avatar
Joined Nov 2006
4,839 Posts
Discussion
Did I just fry my brand new servos ??

Hi ..

I have a couple of HS-645MG analog servos .. the were attached to an 8 ch Futaba RX .. that is capable of High speed mode ... While I was trying to make sure the RX was set to the correct standard mode for these analog servos .. I just switched it to the High speed mode while these analog servos were already connected to the RX... I heard a loud humming sound .. then I quickly disconnected the power to the RX ,,, it only took 1 sec to do so ... now and after I switched back to standard mode .. the servos are working normally .. and no sign of malfunction ...

The question is ...

Can I still trust them .. ?? will that cause them to fail in midair ... I really hate to see this happen because of my stupid mistake

Your advice is greatly appreciated ..

Khaled
khaled_abobakr is offline Find More Posts by khaled_abobakr
Last edited by khaled_abobakr; Apr 13, 2012 at 05:07 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 13, 2012, 05:52 PM
Registered User
Joined Aug 2002
5,811 Posts
Receiver in High Speed Mode with Analogue Servo

Quote:
Originally Posted by khaled_abobakr View Post
Hi .. I have a couple of HS-645MG analog servos .. the were attached to an 8 ch Futaba RX .. that is capable of High speed mode ... While I was trying to make sure the RX was set to the correct standard mode for these analog servos .. I just switched it to the High speed mode while these analog servos were already connected to the RX... I heard a loud humming sound .. then I quickly disconnected the power to the RX ,,, it only took 1 sec to do so ... now and after I switched back to standard mode .. the servos are working normally .. and no sign of malfunction ...
The question is ... Can I still trust them .. ?? will that cause them to fail in midair ... I really hate to see this happen because of my stupid mistake
Your advice is greatly appreciated .. Khaled
High rate causes any analogue servo to jitter and buss which will damage the servo if left to long.
Some cope with it quite well with few jitters, others go beserk. Given servo was connected
for a very brief period and does not display any bad symptons subsequently, it should be all right to continue using.
If doubt exists, use on throttle or one of two ailerons or an accessory, to further
test for a period, where if it dies in midair, total control is not lost.
.
Can the Wrong Setup Burn A Servo Out] (HSS mode in lieu of Normal mode)
Futaba (Bax) answers #1
"<snip>The only time you can damage an analog servo is if you are using an R6008HS or
R6014HS receiver in high speed mode. Analog servos cannot be used on the first six channels
when those receivers are in HS mode.<snip>."
. Futaba High Speed Receiver with Other Brand Servo - Futaba (Bax) answers.#2.
. Futaba Receiver - High Speed Mode - Features explained
"HS mode requires digital servos (channels 1 through 6). Any digital is fine,
it does not require the brushless Futaba servos.
My experience is that with airplanes you will likely not feel any difference.
I've run it in a pattern plane and cannot tell the difference.
It was developed with the extreme 3D heli guys in mind.
HS mode does not increase resolution, reduce latency or make your servos faster.
It increases the speed at which the servo updates its position information which allows it
to develop full holding torque a bit faster. So when pumping the cyclic and collective in a
knife edge tic-toc you will see the advantage, but for normal airplane flying likely not. [/url]

See also sub Section "Glitches & Jitter in Receiver, Servo & ESC - causes and cures " under
"Radio Systems, Accessories, Alterations and FAQ." at:
Alan's Hobby, Model & RC FAQ Web Links

Alan T.
A.T. is offline Find More Posts by A.T.
Reply With Quote
Old Apr 14, 2012, 12:51 PM
There's magic in those wings !
khaled_abobakr's Avatar
Joined Nov 2006
4,839 Posts
Thanks a lot Alan ,,, I think I'll be fine ... I've just installed them in my Zephyer ZII ...

Khaled
khaled_abobakr is offline Find More Posts by khaled_abobakr
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion fried servos and destroyed bec!!! woohoo m1a2ab Electric Heli Talk 4 Apr 04, 2012 12:03 AM
Question Have I fried my ESC's AusTelemetry Multirotor Talk 3 Mar 19, 2012 10:05 AM
Discussion oops i did it again, (or how i crashed my new plane doing stupid stuff) nemoskull Scratchbuilt Indoor and Micro Models 1 Jan 13, 2012 08:44 PM
Discussion fried motor=fried esc and fried rx crypto666 Power Systems 6 Oct 04, 2011 10:23 PM
Did Anybody Watch The Rc Special On The History Channel Fri. Nite?? raythomas Electric Plane Talk 0 May 25, 2002 05:51 PM