HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 30, 2015, 10:08 PM
Quad Virgin
United States, CA, Oakland
Joined Apr 2014
8 Posts
Discussion
KK21 zero indication.

OK, two steps forward, six more roadblocks! I now have the Hero with all the internals connected. Lemon Rx, KK21 FCS, all power up, RX bound to a Turnigy 9X with the Orange Tx module.
I can power everything up and when I go into Rx test on the KK2.1, I see each channel but stick movement produces nothing - all indicators stay at zero.
Any offers?
Cheers
grahambb is offline Find More Posts by grahambb
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 30, 2015, 10:49 PM
Registered User
Oldgazer's Avatar
United States, VA, Richmond
Joined Dec 2013
1,415 Posts
Try disconnecting the receiver from the KK and connecting one of the ESCs to the battery port for power. Then try testing each output with a servo.

Verify you have the cables from the RX to the KK installed properly. The Signal lead goes towards the LCD display and the ground lead goes towards the edge of the circuit board.
Oldgazer is online now Find More Posts by Oldgazer
Reply With Quote
Old Jan 31, 2015, 04:15 PM
Quad Virgin
United States, CA, Oakland
Joined Apr 2014
8 Posts
Quote:
Originally Posted by Oldgazer View Post
Try disconnecting the receiver from the KK and connecting one of the ESCs to the battery port for power. Then try testing each output with a servo.

Verify you have the cables from the RX to the KK installed properly. The Signal lead goes towards the LCD display and the ground lead goes towards the edge of the circuit board.
I connected a servo to the Lemon Rx and each channel drives the servo, but not on the expected stick (Either that or the Lemon instruction sheet is incorrect.....) I connected all to relate to the correct stick movement.

However when I connect back to the KK, still nothing. It all checks out until the KK, which seems to see the Rx, but not respond to any stick inputs. I have doublechecked the jumper cable orientation and they are correct. If I reverse one, the KK says 'no signal'.

I'm really scratching my head now........
grahambb is offline Find More Posts by grahambb
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Glow igniter indicator larryoakley Engines 3 Sep 22, 2014 12:56 PM
Sold Electronics for 450 quad NTM 2826, 30a esc's KK21.15 Diviner Gregg Aircraft - Electric - Multirotor (FS/W) 1 Aug 21, 2014 11:44 PM