HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 22, 2012, 05:26 AM
Registered User
Україна, місто Київ, Київ
Joined Oct 2011
9 Posts
Fundamentally nothing has changed in Umarim Lite.
The absence of the barometer and the presence of usb on the board.
Imho With usb on board will be less convenient.
dzenik is offline Find More Posts by dzenik
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 22, 2012, 09:32 AM
Registered User
Joined Nov 2005
484 Posts
No design will meet everyone's needs. Fortunately if you want to have the USB offboard, a simple USB extension cable can be used to accomplish this. I hope this results in stable hardware that functions properly, that is really the key to continued development.

AJ
AntonK is offline Find More Posts by AntonK
Reply With Quote
Old Mar 22, 2012, 12:58 PM
David1
bmw330i's Avatar
USA
Joined Mar 2007
1,478 Posts
Quote:
Originally Posted by dzenik View Post
Fundamentally nothing has changed in Umarim Lite.
The absence of the barometer and the presence of usb on the board.
Imho With usb on board will be less convenient.
When this design is available then I can see that PPZUAV will make them available without the USB connector as an option. You are welcome to request no USB connector.

I must say I really can't stress enough this design is new, not yet tested, not yet even assembled by anyone. I am posting this information here simply to give encouraging words to everyone that something new is on the way so be patient.

-David
bmw330i is offline Find More Posts by bmw330i
Last edited by bmw330i; Mar 23, 2012 at 10:06 AM. Reason: I said to much earlier. This really is an untested design so I should not create any false expectations.
Reply With Quote
Old Mar 22, 2012, 01:16 PM
Eduardo
Brasil, RS, Porto Alegre
Joined Aug 2008
459 Posts
umarin bare pcb

David, when you have new umarin bare pcb for sale ?

Quote:
Originally Posted by bmw330i View Post
PPZUAV will make them available without the USB connector as an option. You are welcome to request no USB connector.

For the majority of people soldering the USP Programming cable was a big pain. Me included. It is very precise soldering and the solder joint was easily broken (wire to USB pin on the connector). Having the USB on the board means you can use any USB consumer cable. The rest of the cables are much easier. Pre-made cables can be purchased easily. See here: http://thequadshot.com/products/assortment-150mm

This is a a big improvement. The IMU is very close to the processor (short traces less noise). Less cables now. Barometer can be easily connected to the I2C port or SPI port on the board and mounted where you wish on the airframe.

The parts should arrive at the assembly company next week and assembly will commence. target price is 199.00, 299.00 with the Paparazzi GPS13 and cable. Will have bundles for this where what you get is all cabled up and you have most everything you need. Just add RC airframe and connect some wires. Spend more time on the flying.

-David
agressiva is offline Find More Posts by agressiva
Reply With Quote
Old Mar 23, 2012, 10:11 AM
David1
bmw330i's Avatar
USA
Joined Mar 2007
1,478 Posts
Quote:
Originally Posted by agressiva View Post
David, when you have new umarin bare pcb for sale ?
As soon as a few assemblies are made and tested be ENAC I will feel comfortable selling them.

Why the delay? I take a very big risk each time to try and bring prices down for everyone. To make a PCB or assembly inexpensive I have to buy a large amount of parts. If the design is found to have issues I will not sell them and the loss is mine not yours.

I know, there are sites like Alibaba etc who will gladly rush to sell you something untested with inferior parts. I have always hesitated to make anything more than PCBs available until the assemblies are tested. This very thread is full of comments like that from me. Please be patient. The end result is worth it.

-DC
bmw330i is offline Find More Posts by bmw330i
Reply With Quote
Old Apr 02, 2012, 04:22 AM
Registered User
Joined Apr 2012
7 Posts
Hello.

My English is bad.

Two years ago, I was able to fly on planners EasyStar with the autopilot Tiny on board.
Now I want try to do quadrocopter.
I have soldered a BoozMAIN, BoozIMU 1.2 and BoozGPS.

At the ground station as a basis took A/C - BOOZ2_A1 and replaced
<subsystem name="imu" type="b2_v1.1" on <subsystem name="imu" type="b2_v1.2"

after flashing board does not work: LEDs not blink and telemetry data not received.

Can you tell me why the board does not work?
I have little experience in programming and working on Linux, but autopilot Tiny with no problems, everything worked the first time.

Thanks.
-nickmaraev
nickmaraev is offline Find More Posts by nickmaraev
Reply With Quote
Old Apr 02, 2012, 07:03 AM
Eduardo
Brasil, RS, Porto Alegre
Joined Aug 2008
459 Posts
Probably a BAD soldering process.
A assembled TWOG by my self and i need to resold 3 times to board work properly.


Quote:
Originally Posted by nickmaraev View Post
Hello.

My English is bad.

Two years ago, I was able to fly on planners EasyStar with the autopilot Tiny on board.
Now I want try to do quadrocopter.
I have soldered a BoozMAIN, BoozIMU 1.2 and BoozGPS.

At the ground station as a basis took A/C - BOOZ2_A1 and replaced
<subsystem name="imu" type="b2_v1.1" on <subsystem name="imu" type="b2_v1.2"

after flashing board does not work: LEDs not blink and telemetry data not received.

Can you tell me why the board does not work?
I have little experience in programming and working on Linux, but autopilot Tiny with no problems, everything worked the first time.

Thanks.
-nickmaraev
agressiva is offline Find More Posts by agressiva
Reply With Quote
Old Apr 02, 2012, 07:04 AM
Eduardo
Brasil, RS, Porto Alegre
Joined Aug 2008
459 Posts
Bozz

Probably a BAD soldering process.
A assembled TWOG by my self and i need to resold 3 times to board work properly.

The LED processor blink are a most basic function of all PPZ board.
If it not blink you have a basic problem (no power) or assembly problem.

Quote:
Originally Posted by nickmaraev View Post
Hello.

My English is bad.

Two years ago, I was able to fly on planners EasyStar with the autopilot Tiny on board.
Now I want try to do quadrocopter.
I have soldered a BoozMAIN, BoozIMU 1.2 and BoozGPS.

At the ground station as a basis took A/C - BOOZ2_A1 and replaced
<subsystem name="imu" type="b2_v1.1" on <subsystem name="imu" type="b2_v1.2"

after flashing board does not work: LEDs not blink and telemetry data not received.

Can you tell me why the board does not work?
I have little experience in programming and working on Linux, but autopilot Tiny with no problems, everything worked the first time.

Thanks.
-nickmaraev
agressiva is offline Find More Posts by agressiva
Reply With Quote
Old Apr 02, 2012, 07:55 AM
Registered User
Joined Apr 2012
7 Posts
Quote:
Originally Posted by agressiva View Post
Probably a BAD soldering process.
A assembled TWOG by my self and i need to resold 3 times to board work properly.
If the line remain unchanged <subsystem name="imu" type="b2_v1.1" then I get the data from GYRO and ACCEL. LEDs are blinking

Thanks.
-nickmaraev
nickmaraev is offline Find More Posts by nickmaraev
Reply With Quote
Old Apr 02, 2012, 02:06 PM
David1
bmw330i's Avatar
USA
Joined Mar 2007
1,478 Posts
Quote:
Originally Posted by nickmaraev View Post
Hello.

My English is bad.

Two years ago, I was able to fly on planners EasyStar with the autopilot Tiny on board.
Now I want try to do quadrocopter.
I have soldered a BoozMAIN, BoozIMU 1.2 and BoozGPS.

At the ground station as a basis took A/C - BOOZ2_A1 and replaced
<subsystem name="imu" type="b2_v1.1" on <subsystem name="imu" type="b2_v1.2"

after flashing board does not work: LEDs not blink and telemetry data not received.

Can you tell me why the board does not work?
I have little experience in programming and working on Linux, but autopilot Tiny with no problems, everything worked the first time.

Thanks.
-nickmaraev
Hello,

I see it is corrected. Excellent work. That's not an easy board to hand assemble. Congratulations.

-DC
bmw330i is offline Find More Posts by bmw330i
Last edited by bmw330i; Apr 02, 2012 at 02:08 PM. Reason: I see it's resolved
Reply With Quote
Old Apr 02, 2012, 02:56 PM
Registered User
Joined Apr 2012
7 Posts
Quote:
Originally Posted by bmw330i View Post
Hello,

I see it is corrected. Excellent work. That's not an easy board to hand assemble. Congratulations.

-DC
Thanks.

Two days later I finished the frame and motor installation.

-nickmaraev
nickmaraev is offline Find More Posts by nickmaraev
Reply With Quote
Old Apr 04, 2012, 02:11 PM
Registered User
Joined Apr 2012
7 Posts
Hello.
Forgive me for my bad English.

The frame is ready for flight.
But I have a problem with the electronics. As written before, I use a autopilot Booz and Booz IMU 1.2 with compass HMC5843.
Calibration of accelerometers was successful. I'm having trouble with the compass HMC5843. I switched to RAW mode telemetry and found that the data from the compass equal to zero, see screenshot.

I have a few questions:
How to test compass?
Could this bug soldering a compass or a bug in the xml-file?
Can the autopilot Booz to work with Booz IMU v 1.2 or should be used Lisa_m?

Thanks.

-nickmaraev
nickmaraev is offline Find More Posts by nickmaraev
Reply With Quote
Old Apr 04, 2012, 06:30 PM
David1
bmw330i's Avatar
USA
Joined Mar 2007
1,478 Posts
Quote:
Originally Posted by nickmaraev View Post
Hello.
Forgive me for my bad English.

The frame is ready for flight.
But I have a problem with the electronics. As written before, I use a autopilot Booz and Booz IMU 1.2 with compass HMC5843.
Calibration of accelerometers was successful. I'm having trouble with the compass HMC5843. I switched to RAW mode telemetry and found that the data from the compass equal to zero, see screenshot.

I have a few questions:
How to test compass?
Could this bug soldering a compass or a bug in the xml-file?
Can the autopilot Booz to work with Booz IMU v 1.2 or should be used Lisa_m?

Thanks.

-nickmaraev
Hello,

You defined the wrong IMU...from earlier:
"<subsystem name="imu" type="b2_v1.1""

You should have:
<subsystem name="imu" type="b2_v1.2"

Try that.
-David
bmw330i is offline Find More Posts by bmw330i
Reply With Quote
Old Apr 04, 2012, 11:55 PM
Registered User
Joined Apr 2012
7 Posts
Quote:
Originally Posted by bmw330i View Post
Hello,

You defined the wrong IMU...from earlier:
"<subsystem name="imu" type="b2_v1.1""

You should have:
<subsystem name="imu" type="b2_v1.2"

Try that.
-David
Hello, David.
I found this error and corrected before calibration

<subsystem name="radio_control" type="ppm"/>
<subsystem name="telemetry" type="transparent"/>
<subsystem name="actuators" type="asctec"/>
<subsystem name="imu" type="b2_v1.2"/>
<subsystem name="gps" type="ublox">
<configure name="GPS_BAUD" value="B38400"/>
</subsystem>
<subsystem name="stabilization" type="euler"/>
<subsystem name="ahrs" type="int_cmpl_euler"/>
<subsystem name="ins" type="hff"/>

Thanks.

-nickmaraev
nickmaraev is offline Find More Posts by nickmaraev
Reply With Quote
Old May 02, 2012, 01:50 AM
Eduardo
Brasil, RS, Porto Alegre
Joined Aug 2008
459 Posts
Umarin

David, any news about umarin bare pcb ?
agressiva is offline Find More Posts by agressiva
Reply With Quote
Reply


Thread Tools