SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Mar 27, 2015, 09:16 PM
Registered User
United States, NC, Mooresville
Joined Feb 2006
315 Posts
Help!
Drifting problem with CC3D openpilot Please help!

HI

I'm having a problem with a 250 quad racer drifting and fighting me in flight. It normally wants to run forward and left and will do so very fast if you let off the sticks. The problem is worse in Attitude mode. It will fight and fight progressively worse to the point where you feel like you are running out of stick. rate mode will fight but doesn't seem to get worse and worse like attitude. In fact holding one stick position seems good to hold a hover but go back to attitude and it dives forward and right even harder.

I've balanced all my props. The quad sounds good and I surrounded the FC with moongel which is a super soft silicone type of product. I haven't focused to hard on quad CG but I assume it to be pretty close anyway. Even if it was CG I can't see how it just gets worse and worse over a 20-30 second period.

BTW. It seems to reset if you land and take off again.

Should I dump this thing and use a NAZE 32? I'm tired of fighting this.
Rooster433 is offline Find More Posts by Rooster433
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 27, 2015, 09:54 PM
Registered User
Ireland, Dublin, Dublin City
Joined Feb 2014
119 Posts
hi there
i had some similar problems as well
check out this link
it sorted me out

https://forums.openpilot.org/topic/5...l-to-the-left/

jon
ferdy55 is offline Find More Posts by ferdy55
Reply With Quote
Old Mar 27, 2015, 10:02 PM
Registered User
United States, NC, Mooresville
Joined Feb 2006
315 Posts
Hi John, what actaully was your fix? I see several in that thread
Rooster433 is offline Find More Posts by Rooster433
Reply With Quote
Old Yesterday, 07:55 PM
Registered User
United States, NC, Mooresville
Joined Feb 2006
315 Posts
Bump? Any other advice?
Rooster433 is offline Find More Posts by Rooster433
Reply With Quote
Old Today, 11:15 AM
Registered User
HIGHOCTANE32's Avatar
Joined Dec 2013
586 Posts
Have you tried resetting board level? You can quickly tell if that might be the issue by looking at the flight display in GCS with the craft sitting level..does the flight display show it as being level? Also make sure to enable zero gyros when armed, then when you arm let it sit 10-15 seconds before taking off.
HIGHOCTANE32 is online now Find More Posts by HIGHOCTANE32
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! X8R CC3D OpenPilot GCS setup problems Silicon80 Multirotor Talk 0 Jan 20, 2015 06:01 AM
Discussion Please Help- Programming Openpilot CC3D to Turnig 9x transmitter sch0enne Multirotor Electronics 1 Jan 13, 2015 07:04 PM
Sold OpenPilot CC3D board with tomb case, lightly used jason f Aircraft - Electric - Multirotor (FS/W) 0 Apr 30, 2013 09:47 PM
For Sale original openpilot CC3D with tomb case. postalflyer72 Aircraft - Electric - Multirotor (FS/W) 0 Apr 24, 2013 12:21 AM
Sold OpenPilot cc3d with Bluetooth module and shape ways case Friesianflyer Aircraft - Electric - Multirotor (FS/W) 3 Mar 08, 2013 10:43 AM