HobbyKing.com New Products Flash Sale
Closed Thread
Thread Tools
Old Aug 18, 2013, 10:38 AM
Registered User
United States, GA, Atlanta
Joined Dec 2010
2,061 Posts
Quote:
Originally Posted by Overtuner View Post
wanna look at some excercises from my "learnig phase" ?
hehe... now the fun starts... *routing traces and keeping grounds connected* ...

Alan
aadamson is offline Find More Posts by aadamson
Last edited by aadamson; Aug 18, 2013 at 12:28 PM.
Sign up now
to remove ads between posts
Old Aug 18, 2013, 12:28 PM
Registered User
Poland
Joined Jul 2011
126 Posts
Quote:
Originally Posted by user1 View Post
Didn't see anyone else comment on this.
I have a 1.2 board and it would appear the crystal is shorted.
Thanks
As Alan already answered - you probably have the 2-pad crystal. This bug may occur only if you assemble on your own and by mistake use 4-pad crystal
acc007 is offline Find More Posts by acc007
Old Aug 18, 2013, 12:37 PM
Registered User
United States, GA, Atlanta
Joined Dec 2010
2,061 Posts
Ok, let's start a little *what works* post.

This is an OPEN SOURCE HARDWARE and SOFTWARE 3 axis solution. There are some commercially available copies of the 1.2 version. When evaluating those options, please make sure you pick the one that has been modified with the addition of the 3k3 resistors on the low side FET's... This was incorporated in the 1.3 redesign, but the 1.2 board from some vendors have been modified by soldering the resistors across the BSS chips already.

As of 2013/8/18 I know of now commercially available 1.3 boards, they are completely a DIY solution.

1.2/1.3 boards
PWM is running at 18khz on the 0.3g and up firmware, up from the 8khz that was in the 0.3e and below used.
Autopan was working on Yaw axis only in 0.3e and below, in 0.3g and above, I believe it was also enabled on one of the other axis.
RX control works on 2 of the axis (I'll have to check the code to see which unless someone knows?)

Hardware
All hardware files are located in the github repo
https://github.com/EvvGC/Hardware

As of 2013/8/18, the current version is the pre1.3ce2 version. It is very new and most people are just building boards currently. It was generated to resolve some fundamental issues with the 1.2 solution. There are pull down resistors on both the high and the low side FET's. The usb interface was corrected to include inline resistors and the appropriate disconnect for host enumeration. Most high power traces were increase in size by 30-50%, an attempt at providing 50-100% more heatsink capability to the high voltage FETs was included. The board is single sided. Additional LED's were added for power and user configuration. the 1.3 and 1.2 boards are fully interchangeable from a software standpoint with one exception. The 1.3 board has the markings for the Pitch and Roll attachment reversed. While this matches the schematic, it doesn't match the firmware. We'll correct this most likely in the future, but for now when running the 1.3 hardware, you'll need to connect the Pitch motor to the header marked Roll and the Roll motor to the header marked Pitch.

Firmware
All firmware versions are located in the github repo
https://github.com/EvvGC/Firmware

NOTE on the firmware repos.... The *master branch* is the latest 0.3g firmware setup to build under eclipse. It will only run with optimizations disabled... If you follow the instructions for setting up a build environement, you won't have any problems here.

The original firmware is in the original-src directory

The *Experimental* branch is just that, use at your own risk... I has a number of fixes to the original source that correct a number of time, timer, deadband issues... But it's very early in it's testing and one user experienced a hardware problem that we've be unable to determine if software caused. Others are using it just with no issues....

IMU
- ONLY support for the MPU 6050 I2C sensor.... Other I2C only sensors could be used, but software only supports the MPU 6050 at the moment... (In theory the 6000 would work two, but only on the I2C bus)

Motors
- 22xx series motors with 80 turn wiring
- I think there are some 3xxx series motors that would work I just don't know what the model numbers are
- 40xx series motors (not sure what the turns are here)
- 50xx series motors (I think these are 100 turn motors)
- 5206's - pretty sure this is the limit on this board.

Batteries
- 2S - not sure I'd go this low, but probably would work in a pinch
- 3S - sweet spot most likely
- 4S - 1.2 board may have some issues here as some components were only spec'd at 15V

1.3 only
- 5S - needs further testing, will most likely be the max on a 1.3 board
- 6S - in theory this should work... HOWEVER, the 3v3 regulator and the filter cap on the motor side of things are only rated to 25V. There are some other components, but they should all be on the 3v3 buss that are rated at 15v... I need to check a couple of diodes on the high power bus to make sure everything is rated to at least 25v... The FET's all max out at 30 so nothing larger than 6S (and one user showed signs of smoke when instantly connecting a 6S battery).... For now, I would stay away from 6S and only 5 or 6 on the 1.3 board, it will smoke components on the 1.2 board. (even at 25V, there is no margin with some of the components on the high power bus 6S lipo is 24.x and most items are rated to 25v only).

Alan
aadamson is offline Find More Posts by aadamson
Last edited by aadamson; Aug 18, 2013 at 01:00 PM.
Old Aug 18, 2013, 01:02 PM
Registered User
United States, GA, Atlanta
Joined Dec 2010
2,061 Posts
In typing all the above I just remember...

For those that are running the 1.3 board..

REMEMBER
Pitch motor must be connected to ROLL connector and Roll motor must be connected to PITCH connector... That was a change between 1.2 and 1.3...

Alan
aadamson is offline Find More Posts by aadamson
Old Aug 18, 2013, 01:40 PM
Registered User
United States, GA, Atlanta
Joined Dec 2010
2,061 Posts
Ok everyone I got sick and tired of waiting...

I would strongly suggest that you move all future discussions to this thread... that way *I* can stop typing the same stuff every time ...

http://www.rcgroups.com/forums/showthread.php?t=1978860

If I knew of a way to close this thread I would ...
aadamson is offline Find More Posts by aadamson
Last edited by aadamson; Aug 18, 2013 at 04:25 PM.
Old Aug 18, 2013, 03:36 PM
Registered User
Joined Nov 2011
41 Posts
Anyway of troubleshooting this board for faults.
hitinson is offline Find More Posts by hitinson
Old Aug 18, 2013, 03:39 PM
evvGC - 2208 KV80 - 3s LiPo
United States, SC, Charleston
Joined Jul 2013
45 Posts
Quote:
Originally Posted by aadamson View Post
Ok everyone I got sick and tired of waiting...

I would strongly suggest that you move all future discussions to this thread... that way *I* can stop typing the same stuff every time ...

http://www.rcgroups.com/forums/showp...59&postcount=1

If I knew of a way to close this thread I would ...
Might want to create a couple "placeholder" posts at the beginning just in case you need more space later on, or to logically group some of the info to a linkable post...
texSC is offline Find More Posts by texSC
Old Aug 18, 2013, 03:54 PM
Registered User
United States, GA, Atlanta
Joined Dec 2010
2,061 Posts
Quote:
Originally Posted by texSC View Post
Might want to create a couple "placeholder" posts at the beginning just in case you need more space later on, or to logically group some of the info to a linkable post...
I think I did that ...
aadamson is offline Find More Posts by aadamson
Old Aug 18, 2013, 03:56 PM
Registered User
United States, GA, Atlanta
Joined Dec 2010
2,061 Posts
Quote:
Originally Posted by hitinson View Post
Anyway of troubleshooting this board for faults.
Please move the question to here if you would please?

http://www.rcgroups.com/forums/showt...0#post25877559

Alan
aadamson is offline Find More Posts by aadamson
Old Aug 18, 2013, 04:19 PM
evvGC - 2208 KV80 - 3s LiPo
United States, SC, Charleston
Joined Jul 2013
45 Posts
Quote:
Originally Posted by aadamson View Post
I think I did that ...
oh haha, yes you did, nice! I just clicked the link you had above but it was just to a single post & I didn't realize it, lol
texSC is offline Find More Posts by texSC
Old Aug 18, 2013, 04:25 PM
Registered User
United States, GA, Atlanta
Joined Dec 2010
2,061 Posts
Now if we can just move all the conversation over to this thread...

http://www.rcgroups.com/forums/showthread.php?t=1978860
aadamson is offline Find More Posts by aadamson
Old Aug 19, 2013, 09:26 AM
Registered User
Joined Apr 2007
19 Posts
Quote:
Originally Posted by Overtuner View Post
Ladies and Gentlemen,
we proudly present:
the first running prototype of EvvGC V2 with 4 to 6 axis support.


first tests:
3S, 2x IPower motors GBM5206 150turns, firmware 0.3g, motor power 65%, 0,65 amps per motor torque: ~180gramms on a 90mm arm
motors get warm ~48C, drivers w/o cooling went to 50~55C

+ no more blown FET's anymore, half of the STM32's i/o pins
- 4S only (20V absolute maximum)

cheers
Lutz
Is there a software GUI for this? And are the newer boards ( 3 axis support ) up for order? There are several boards in the airbot shop, but without any clarification or information on what is needed its totally undo-able for newbie's like me to figure this out. Also there are no good motors to supplement in the air bot shop (?) Would be nice to order everything needed from 1 shop.
jorrie is offline Find More Posts by jorrie
Old Aug 19, 2013, 09:30 AM
Registered User
United States, GA, Atlanta
Joined Dec 2010
2,061 Posts
Quote:
Originally Posted by jorrie View Post
Is there a software GUI for this? And are the newer boards ( 3 axis support ) up for order? There are several boards in the airbot shop, but without any clarification or information on what is needed its totally undo-able for newbie's like me to figure this out. Also there are no good motors to supplement in the air bot shop (?) Would be nice to order everything needed from 1 shop.
Please move all future post to this thread...

http://www.rcgroups.com/forums/showthread.php?t=1978860

Commercially there is only the v1.2 board available, there is a mod that needs to be done to it and the only commercial company that is doing this mod is the myairbot guys.

There is also a simple GUI available, please reference post one in this thread.

Motors and gimbal are a whatever you want, but the first post in the new thread above covers that.

We are trying to move everything to the new thread, so please continue the discuss there...

Thanks,
Alan
aadamson is offline Find More Posts by aadamson
Old Aug 19, 2013, 02:13 PM
Registered User
Poland
Joined Jul 2011
126 Posts
Guys, great news! USB works for GUI with experimenal code !
Check it out here - http://www.rcgroups.com/forums/showp...1&postcount=33
acc007 is offline Find More Posts by acc007
Last edited by acc007; Aug 19, 2013 at 02:16 PM. Reason: linked to proper thread
Old Aug 20, 2013, 10:24 AM
Registered User
Joined Jul 2013
24 Posts
next HERO2 works ..

Lipany SLOVAKIA - mini showreel (1 min 17 sec)


coming soon next piece evadlis board for testing ...
hcmpromotion is offline Find More Posts by hcmpromotion
Closed Thread


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Open Source Brushless Gimbal edge0xc Multirotor Electronics 3045 Aug 12, 2014 02:19 PM
Idea Open Source Gopro Brushless Gimbal icais Multirotor Talk 16 Mar 28, 2014 12:07 PM
Discussion SkyLight SBG - GoPro 2 Version Released (+ GP3 Beta + 3 axis Alpha) !! ed_jza80 Multirotor Talk 494 Jan 03, 2014 10:09 AM
Sold open source brushless gimbal controller jy0933 Aircraft - Electric - Multirotor (FS/W) 57 Mar 26, 2013 07:02 PM
Sold [closed] open source brushless gimbal controller jy0933 Aircraft - Electric - Multirotor (FS/W) 16 Feb 26, 2013 09:19 AM