HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 09, 2012, 07:32 AM
Oh no not another one
Mansfield, Nottinghamshire UK
Joined Jan 2011
275 Posts
Help!
Buzzflyer FE/Walkera V100D01 brushless troubleshooting

I have just completely rebuilt this heli which had a split tail boom glued into the main frame so both have been carefully renewed and all appears to work fine. The tail rotor wires were stuck in the glued joint but I managed to get them out intact and the tail responds fine to all rudder trims and commands.

My problem is that that the heli is completely unstable, shooting off in any direction when I try a lift off, and further investigation reveals an even weirder fault. Holding the heli and running at full throttle on a fully charged battery causes it to cut all motor power after only a few seconds and the LED on the receiver board goes to flashing state as this happens. Both servos will still respond to the Tx but it has to be powered down and re-paired to get a steady LED and response from the motors.

It will run for longer in "beginner"mode at 30-80% throttle but still cuts off just the same in around a minute. Battery voltage is still over 4v when this happens and I have tried several batteries. I am suspecting either the Tx or Rx may be faulty but wondered if anyone else has experienced this or a similar problem on Walkera helis.

As it could be a motor or ESC problem I don't want to buy a new Rx or Tx without a bit more proof if anyone can help.

Thanks in advance

Ian
eyemdee is offline Find More Posts by eyemdee
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 09, 2012, 07:40 AM
Registered User
Joined Dec 2007
6,515 Posts
Quote:
Originally Posted by eyemdee View Post
I have just completely rebuilt this heli which had a split tail boom glued into the main frame so both have been carefully renewed and all appears to work fine. The tail rotor wires were stuck in the glued joint but I managed to get them out intact and the tail responds fine to all rudder trims and commands.

My problem is that that the heli is completely unstable, shooting off in any direction when I try a lift off, and further investigation reveals an even weirder fault. Holding the heli and running at full throttle on a fully charged battery causes it to cut all motor power after only a few seconds and the LED on the receiver board goes to flashing state as this happens. Both servos will still respond to the Tx but it has to be powered down and re-paired to get a steady LED and response from the motors.

It will run for longer in "beginner"mode at 30-80% throttle but still cuts off just the same in around a minute. Battery voltage is still over 4v when this happens and I have tried several batteries. I am suspecting either the Tx or Rx may be faulty but wondered if anyone else has experienced this or a similar problem on Walkera helis.

As it could be a motor or ESC problem I don't want to buy a new Rx or Tx without a bit more proof if anyone can help.

Thanks in advance

Ian
You are not supposed to hold a heli down and run it at full throttle. The heli wants to lift and holding it down causes a huge spike in current draw and heats up the FETs on the main board or the ESC. What you are experiencing may be a thermal or over current shutdown protection.

It's like hooking VW Beetle up to a 100ft yacht on a trailer, flooring it for a minute and then wondering why the car shut down.
Xrayted is offline Find More Posts by Xrayted
Last edited by Xrayted; Dec 09, 2012 at 07:51 AM.
Reply With Quote
Old Dec 09, 2012, 08:16 AM
Oh no not another one
Mansfield, Nottinghamshire UK
Joined Jan 2011
275 Posts
Quote:
Originally Posted by Xrayted View Post
You are not supposed to hold a heli down and run it at full throttle. The heli wants to lift and holding it down causes a huge spike in current draw and heats up the FETs on the main board or the ESC. What you are experiencing may be a thermal or over current shutdown protection.

It's like hooking VW Beetle up to a 100ft yacht on a trailer, flooring it for a minute and then wondering why the car shut down.
Yes I know this and I was wondering why it wasn't pulling very hard even at full throttle. I have just discovered that of the 8 batteries that came with this and another Walkera heli, only 2 are the genuine item and work fine! The other 6 are completely useless fakes and the problem was indeed low voltage cutout.

Just got to learn to fly it properly now. Not as easy as a Solo Pro or Blade MSR by the looks of things!
eyemdee is offline Find More Posts by eyemdee
Reply With Quote
Old Dec 09, 2012, 09:22 AM
Registered User
Joined Dec 2007
6,515 Posts
Quote:
Originally Posted by eyemdee View Post
Yes I know this and I was wondering why it wasn't pulling very hard even at full throttle. I have just discovered that of the 8 batteries that came with this and another Walkera heli, only 2 are the genuine item and work fine! The other 6 are completely useless fakes and the problem was indeed low voltage cutout.

Just got to learn to fly it properly now. Not as easy as a Solo Pro or Blade MSR by the looks of things!
Ah, yes. It's possible the crappy batteries cannot sustain voltage under load and just bottom out on you immediately.

The Solo Pro and MSR are self stabilizing helis that return to neutral when you center the sticks. They basically hover themselves. This one will keep moving whatever direction you last sent it until you counter with another input.
Xrayted is offline Find More Posts by Xrayted
Reply With Quote
Old Dec 09, 2012, 09:34 AM
Oh no not another one
Mansfield, Nottinghamshire UK
Joined Jan 2011
275 Posts
Quote:
Originally Posted by Xrayted View Post
Ah, yes. It's possible the crappy batteries cannot sustain voltage under load and just bottom out on you immediately.

The Solo Pro and MSR are self stabilizing helis that return to neutral when you center the sticks. They basically hover themselves. This one will keep moving whatever direction you last sent it until you counter with another input.
Yes, not only did the batteries bottom out almost immediately but sent the swash all over the place under power so lifting off was impossible. I noticed the lack of self stabilising while I was holding it looking for the non existent fault!
eyemdee is offline Find More Posts by eyemdee
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-Review Walkera V100D01 Review with Pictures, Video, Flight Times, Motor and Pinion Options Tom Z Micro Helis 2035 Yesterday 09:45 AM
Sold MCPX Brushless - CHEAP - You Troubleshoot? ee4air Aircraft - Electric - Helis (FS/W) 0 Oct 14, 2012 06:02 PM
Discussion Walkera V100D01 NOW SHIPPING at www.WowHobbies.com wowhobbies Micro Helis 91 Sep 13, 2010 02:32 AM
Discussion New Walkera v100d01 ehirobo Micro Helis 9 Sep 08, 2010 09:49 PM