SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Closed Thread
Thread Tools
Old Dec 02, 2012, 06:14 AM
OS Sponsor
kinderkram's Avatar
Germany, NRW, Dusseldorf
Joined Jun 2010
5,395 Posts
@ Joe: did you already have a chance to test the new AC2.8 port from Sir Alex?
http://code.google.com/p/megapiraten...e/detail?r=245
kinderkram is offline Find More Posts by kinderkram
RCG Plus Member
Sign up now
to remove ads between posts
Old Dec 02, 2012, 06:14 AM
Registered User
jabram's Avatar
Australia, NSW, Kendall
Joined Jul 2012
5,483 Posts
@whitespy, you've been busy, good work.

All these options, it must be Christmas
jabram is offline Find More Posts by jabram
RCG Plus Member
Old Dec 02, 2012, 06:17 AM
Registered User
jabram's Avatar
Australia, NSW, Kendall
Joined Jul 2012
5,483 Posts
Quote:
Originally Posted by kinderkram View Post
@ Joe: did you already have a chance to test the new AC2.8 port from Sir Alex?
http://code.google.com/p/megapiraten...e/detail?r=245
Norbert, no I haven't tried AC2.8 from Sir Alex yet, I have been playing with Arduflyer APM 2.5 plus other life distractions.

Joe
jabram is offline Find More Posts by jabram
RCG Plus Member
Old Dec 02, 2012, 06:22 AM
Registered User
jabram's Avatar
Australia, NSW, Kendall
Joined Jul 2012
5,483 Posts
@subaru4wd,

I missed your post since it doesn't show up unless I get brave

Installing MP NG should be the same as the HK Mega I used originally.
jabram is offline Find More Posts by jabram
RCG Plus Member
Old Dec 02, 2012, 11:42 AM
we dont NEED roads!
AcroFPV's Avatar
United States, CA, Rocklin
Joined Aug 2012
3,428 Posts
Thank you everybody.

And a big thanks to witespy! I can't wait to get my hands on this board!
AcroFPV is online now Find More Posts by AcroFPV
Old Dec 02, 2012, 08:11 PM
Registered User
Australia, NSW
Joined Sep 2006
138 Posts
Quote:
Originally Posted by jabram View Post
Installing MP NG should be the same as the HK Mega I used originally.
Except choose PIRATES_FREEIMU_4 as the board type i believe.
LegendLength is offline Find More Posts by LegendLength
Old Dec 02, 2012, 08:17 PM
Registered User
Clavin01's Avatar
USA, MD, Glen Burnie
Joined Sep 2008
130 Posts
Multiwii pro

Hello All
OK here is my progress, Loaded Multi wii with changes, Then Megapirates
Down loaded Flight Planner. Cleared Eeffrom, but when I try to connect
it can not find Mavlink or it is not recieving good packets, Does anyone
Know what this is?? and how do I fix it. Thanks for any help
Cliff (Clavin01)
Clavin01 is offline Find More Posts by Clavin01
Old Dec 02, 2012, 08:38 PM
Registered User
Australia, NSW
Joined Sep 2006
138 Posts
Quote:
Originally Posted by Clavin01 View Post
Hello All
OK here is my progress, Loaded Multi wii with changes, Then Megapirates
Down loaded Flight Planner. Cleared Eeffrom, but when I try to connect
it can not find Mavlink or it is not recieving good packets, Does anyone
Know what this is?? and how do I fix it. Thanks for any help
Cliff (Clavin01)
Does it connect using telnet within mission planner?
LegendLength is offline Find More Posts by LegendLength
Old Dec 02, 2012, 08:52 PM
Registered User
Clavin01's Avatar
USA, MD, Glen Burnie
Joined Sep 2008
130 Posts
Mission Planner

How do you use telnet with in Mission Planner?

Is that the tcp in Ports?
Clavin01 is offline Find More Posts by Clavin01
Old Dec 02, 2012, 11:02 PM
Registered User
jabram's Avatar
Australia, NSW, Kendall
Joined Jul 2012
5,483 Posts
Quote:
Originally Posted by Clavin01 View Post
Hello All
OK here is my progress, Loaded Multi wii with changes, Then Megapirates
Down loaded Flight Planner. Cleared Eeffrom, but when I try to connect
it can not find Mavlink or it is not recieving good packets, Does anyone
Know what this is?? and how do I fix it. Thanks for any help
Cliff (Clavin01)
Make sure you selected correct COM Port and 115200 when connecting using USB, also make sure no other program is already connected to that USB Com Port.

Wait for the slow drop down list in APM Planner to find all USB ports.

If you have 3DRadio or Bluetooth make sure it is not already connected to another instance of APM Planner.

If all that doesn't work - close APM Planner, unplug USB, wait 30 seconds, plug USB in, start APM Planner select 115200 baud and the correct Com Port, click on APM Planner Connect.
jabram is offline Find More Posts by jabram
RCG Plus Member
Old Dec 02, 2012, 11:03 PM
Registered User
jabram's Avatar
Australia, NSW, Kendall
Joined Jul 2012
5,483 Posts
Quote:
Originally Posted by LegendLength View Post
Except choose PIRATES_FREEIMU_4 as the board type i believe.
Oh yeah, different sensors ? did you test that selection on whitespy Mega ?
jabram is offline Find More Posts by jabram
RCG Plus Member
Old Dec 02, 2012, 11:46 PM
Registered User
Australia, NSW
Joined Sep 2006
138 Posts
Quote:
Originally Posted by jabram View Post
Oh yeah, different sensors ? did you test that selection on whitespy Mega ?
Yes sorry it's a whitespy mega. I think he said it in a different thread. But I'm still having issues setting up the gyros so it may be incorrect.

I have an issue where the gyros are correct but the stick controls aren't. This is how it is currently (quadx config):

- pitch forward causes the quad to roll right
- pitch backward causes the quad to roll left
- roll left causes the quad to pitch backward
- roll right causes the quad to pitch forward

I have all of the gyros working correctly though, it's strange. I had to change the motor wiring from the standard D2, D5, D3, D6 because it was not working correctly for either stick input or gyros (using this reference http://code.google.com/p/megapirate/wiki/Motors ).

I am using turnigy 9x without any firmware upgrade and all trims are zero and channel directions are non-reversed.

Edit: The channels all show up correctly in mission planner.

Edit2: Actually the artificial horizon pitches when i roll in mission planner. Is there a setting somewhere to reverse the gyros? The board is facing the front of the chopper.
LegendLength is offline Find More Posts by LegendLength
Last edited by LegendLength; Dec 03, 2012 at 12:04 AM.
Old Dec 03, 2012, 12:47 AM
Registered User
jabram's Avatar
Australia, NSW, Kendall
Joined Jul 2012
5,483 Posts
Quote:
Originally Posted by LegendLength View Post
Yes sorry it's a whitespy mega. I think he said it in a different thread. But I'm still having issues setting up the gyros so it may be incorrect.

I have an issue where the gyros are correct but the stick controls aren't. This is how it is currently (quadx config):

- pitch forward causes the quad to roll right
- pitch backward causes the quad to roll left
- roll left causes the quad to pitch backward
- roll right causes the quad to pitch forward

I have all of the gyros working correctly though, it's strange. I had to change the motor wiring from the standard D2, D5, D3, D6 because it was not working correctly for either stick input or gyros (using this reference http://code.google.com/p/megapirate/wiki/Motors ).

I am using turnigy 9x without any firmware upgrade and all trims are zero and channel directions are non-reversed.

Edit: The channels all show up correctly in mission planner.

Edit2: Actually the artificial horizon pitches when i roll in mission planner. Is there a setting somewhere to reverse the gyros? The board is facing the front of the chopper.
Your description seems to show that the front is what you actually think is the right side, I seem to recall an arrow on a whitespy board that later changed, ask on the whitespy Mega forum.

If you treat the right side as the front, and wire the motors accordingly, does that work? you may have edit MAG in Arduino code.
jabram is offline Find More Posts by jabram
RCG Plus Member
Old Dec 03, 2012, 07:02 AM
Registered User
Australia, NSW
Joined Sep 2006
138 Posts
Quote:
Originally Posted by jabram View Post
Your description seems to show that the front is what you actually think is the right side, I seem to recall an arrow on a whitespy board that later changed, ask on the whitespy Mega forum.

If you treat the right side as the front, and wire the motors accordingly, does that work? you may have edit MAG in Arduino code.
Yes that fixed it thanks again god / jabram!
LegendLength is offline Find More Posts by LegendLength
Old Dec 03, 2012, 11:21 AM
Registered User
jabram's Avatar
Australia, NSW, Kendall
Joined Jul 2012
5,483 Posts
@LegendLength
Glad it worked, happy to help.
jabram is offline Find More Posts by jabram
RCG Plus Member
Closed Thread


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion [UNOFFICIAL] New HobbyKing MultiWii PRO Flight Controller w/MTK GPS Module benybee UAV - Unmanned Aerial Vehicles 408 Dec 08, 2014 02:10 PM
Help! PROBLEM on Crius AIO Pro Y6 With MegaPirate NG 2.7 R4. RQuad Multirotor Electronics 3 Jan 22, 2013 01:13 AM
Found MultiWii PRO Flight Controller w/MTK GPS Module Koo Aircraft - Electric - Multirotor (FS/W) 4 Oct 11, 2012 12:47 AM
Yippee! New AirStudio universal Flight Controller for Mega Pirate NG and MultiWii AirCopter Multirotor Electronics 44 Sep 10, 2012 05:56 AM