HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 29, 2010, 10:00 AM
Cookies Good - Bacon Better
NoMatta's Avatar
Portland, Oregon
Joined Sep 2008
1,594 Posts
Nevermind
NoMatta is offline Find More Posts by NoMatta
Last edited by NoMatta; Aug 29, 2010 at 10:31 AM. Reason: I give up
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 29, 2010, 10:00 AM
BANG IT!!!
DaOldGuy's Avatar
United States, PA, Bellefonte
Joined Dec 2007
12,245 Posts
Quote:
Originally Posted by Dad_Roman View Post

Yall check that (#)@#&( under lololol
What???? That is nothing out of sorts for this group, with there was that time... you know....PB said....
DaOldGuy is offline Find More Posts by DaOldGuy
Last edited by DaOldGuy; Aug 30, 2010 at 11:49 AM.
Reply With Quote
Old Aug 29, 2010, 11:31 AM
3.14159265358979323846264
rccardude04's Avatar
Wichita, Ks
Joined Jun 2005
1,986 Posts
DOG, you really need to remove that quote...

either way i'm glad that's over.

-Eric
rccardude04 is offline Find More Posts by rccardude04
Reply With Quote
Old Aug 29, 2010, 11:39 AM
Twistaholic AMA 134406
Dad_Roman's Avatar
USA, TX, Teague
Joined Jul 2007
5,614 Posts
ROFLMAO.....


....oh crap....I guess I shouldnt be laughing about this.
Dad_Roman is offline Find More Posts by Dad_Roman
Reply With Quote
Old Aug 29, 2010, 12:08 PM
Registered User
Joined Jul 2010
172 Posts
This is kind of a sad one...
Yesterday I had my TT40 out for only its second trip to the field. Had an rx batt failure and stuffed her. Everything broke. Fuse splintered and broke completely apart in 3 places. Tail is tacoed. Wing is shattered. Nothing to repair. Least I still have the T__T60.

Here are some vid highlights of its last day with us. The end is a tail drag in tribute to the hos

http://vimeo.com/14521932
Dave_45 is offline Find More Posts by Dave_45
Reply With Quote
Old Aug 29, 2010, 12:14 PM
Registered User
North vancouver, B.C. Canada
Joined Apr 2008
18,501 Posts
Dang you are good Dave

got video of the crash?
David22 is offline Find More Posts by David22
Reply With Quote  (Disabled)
Old Aug 29, 2010, 12:31 PM
A trail of smoke is GOOD!
waynemia's Avatar
USA, TX, Springtown
Joined May 2008
7,226 Posts
Quote:
Originally Posted by Dave_45 View Post
This is kind of a sad one...
Yesterday I had my TT40 out for only its second trip to the field. Had an rx batt failure and stuffed her. Everything broke. Fuse splintered and broke completely apart in 3 places. Tail is tacoed. Wing is shattered. Nothing to repair. Least I still have the T__T60.

Here are some vid highlights of its last day with us. The end is a tail drag in tribute to the hos
Well Done Dave. That deserves a spot on the ho down thread for sure. Longest steadiest I have seen and t-rolls too.
waynemia is offline Find More Posts by waynemia
Reply With Quote
Old Aug 29, 2010, 01:15 PM
Twistaholic AMA 134406
Dad_Roman's Avatar
USA, TX, Teague
Joined Jul 2007
5,614 Posts
Daaaang Dave...short life for the 40


Keep an eye out and get ya another one
Dad_Roman is offline Find More Posts by Dad_Roman
Reply With Quote
Old Aug 29, 2010, 07:14 PM
Cookies Good - Bacon Better
NoMatta's Avatar
Portland, Oregon
Joined Sep 2008
1,594 Posts
Wait a minute, what happened to no vid, it didn't happen. No vid of the crash or carnage, must not have happened.

Sorry for the loss, but all the parts could fit a new one, right

Got some flying in today. The Edge and Christine. Last flight of the day (of course) the Edge decided to turn right instead of left and tried to move the support for the pilot's box. Some wing damage, 'bout a two hour fix.

We got to watch Plowboy. Seems he now has a hot tub. Talked to him yesterday, just got out of the hot tub. Talked to him this afternoon, staying home with his honey. And the hot tub. Quick, someone send him a T---t.

Our bud is now officially moved. Still unpacking, but feeling relief at the conclusion of the real estate deal.
NoMatta is offline Find More Posts by NoMatta
Last edited by NoMatta; Aug 29, 2010 at 11:00 PM. Reason: Can't spell
Reply With Quote
Old Aug 29, 2010, 10:05 PM
Montana Transplant
mt_flyer's Avatar
United States, OR, Klamath Falls
Joined Aug 2005
1,930 Posts
found the YS problem... fuel pump plunger worn out... won't shut off fuel when not running... too much fuel when running... parts on the way...
runs well with the pump adjustment just cracked open...only slight drip now, and the parts will fix that..
mt_flyer is offline Find More Posts by mt_flyer
Reply With Quote
Old Aug 29, 2010, 11:43 PM
Crazy Pilot-gone insane...
United States, CT, Norwalk
Joined Nov 2009
118 Posts
Electric Twist 60...really?

Hi all!

I posted a few days ago with what I should put in my 60 Twist (electric motor wise). I decided to go the Turnigy 50-55 580 KV route swinging (for starters) a 14x7 prop.

I am having a weird issue trying to use a watt meter though. See the pic with two batteries in series to reference. For some reason, ( I have not tried another pack yet) when I attempt to get a reading from my Astro Watt meter, its stops at 12.45 amps and around 240 watts. It will read batter voltage, and the motor will get to full throttle, but I can't get a reading. Any help here would be great- I am sure by guessing that I am within my limits ( I have another setup with this motor and a 13x8 prop that pulls about 70 amps-I dropped a pitch and increased length each by an inch-the worst is a 5 amp ish increase I would think...).

Enjoy these photos of the completed build-she doesn't get any stickers until AFTER a successful maiden day, hopefully tommorow!

Do you guys thing that with the above noted issue that it would be safe to fly? Let me know. I also could not seem to get the plane to balance with the 3.3 aH pack- I could just barely get it to 6 inches with the Hyperion 6s 5000 pack pictured as well. The Thunder Power pack is just another that is a hair lighter and will be more fun to fly with once I am used to the airframe. Let me know guys!

Best,

Chris
harttvboy is offline Find More Posts by harttvboy
Reply With Quote
Old Aug 30, 2010, 08:04 AM
Walk of Shame Season :)
Waldopepperaxe's Avatar
NY
Joined Jun 2008
4,894 Posts
Dave 45 thats a bummer man and yes you had the huck on for sure but if you would like to take on a little project. here is a link on how to repair her or just build a new one from scratch. This is just why we made this thread.
http://www.rcgroups.com/forums/showt...0#post13728563

Nice Pics Harttvboy looking great

MT Flyer Glad to hear you figured out the problem thats always a relief

Plow has a Hot tub whens the House warming party.

I think our snowman melted in the heat this summer

Dad go ahead and LOL,,, it is pretty dang funny, especially because were T_ _ _ Taholics we can take it
Waldopepperaxe is offline Find More Posts by Waldopepperaxe
Reply With Quote
Old Aug 30, 2010, 08:13 AM
A trail of smoke is GOOD!
waynemia's Avatar
USA, TX, Springtown
Joined May 2008
7,226 Posts
Quote:
Originally Posted by harttvboy View Post
Hi all!
I am having a weird issue trying to use a watt meter though. See the pic with two batteries in series to reference. For some reason, ( I have not tried another pack yet) when I attempt to get a reading from my Astro Watt meter, its stops at 12.45 amps and around 240 watts. It will read batter voltage, and the motor will get to full throttle, but I can't get a reading. Any help here would be great- I am sure by guessing that I am within my limits ( I have another setup with this motor and a 13x8 prop that pulls about 70 amps-I dropped a pitch and increased length each by an inch-the worst is a 5 amp ish increase I would think...).

Do you guys thing that with the above noted issue that it would be safe to fly? Let me know. I also could not seem to get the plane to balance with the 3.3 aH pack- I could just barely get it to 6 inches with the Hyperion 6s 5000 pack pictured as well. The Thunder Power pack is just another that is a hair lighter and will be more fun to fly with once I am used to the airframe. Let me know guys!

Best,

Chris
Hi Chris,

"Wierd" is not a good thing with electronics. You have a 70A meter and you should be getting more current indicated on that setup. I would check the meter on another setup first. See if the meter is defective.

I looked at the pictures and it looks like you have the packs in series correctly. 12.45A @ 240W is just 19.28V. This is much lower than it should be. Perhaps the batteries are not fully charged or the packs are not balanced.

Also, that motor is rated for 29V max voltage. You may need more voltage to get the maximum power from the motor.

JMHO but I would sort out the problem before flying.
waynemia is offline Find More Posts by waynemia
Reply With Quote
Old Aug 30, 2010, 11:11 AM
A trail of smoke is GOOD!
waynemia's Avatar
USA, TX, Springtown
Joined May 2008
7,226 Posts
EZ* with Smoke

Here is the vid of the EZ* and smoke. It is 7.5 minutes long because I tried to show all the parts and setup. It is not elegant, I want to see how it works first and I wanted it removeable.

The cap is very tight and impossible to get on with the igniter wires hanging out. I cut a slot in the side to get the cap on. On the first test, the igniter went off and blew the clear plastic cap off. The igniter lights a piece of fuse like fireworks has. Without the fuse the smoke cartridge will not ignite.

The second flight, in the video, I taped the cap on with blenderm tape. That held the cap tight. It was still on the cap when It came down.

The first flight, I just landed on the ground. That was tough on the belly mount and cracked the little ply I had it mounted on. On the second flight, the guy shooting the video caught the plane. Burn time is about 3 1/2 minutes. We had 9 to 10mph wind and that was blowing the smoke but stll pretty good. I only made the one flight with smoke. On a calmer day, I will do it again and make some lower passes over the runway.

I am short an igniter now. I ordered some more canisters, assorted colors, and extra igniters.

Easy Star SmokeTest (7 min 42 sec)
waynemia is offline Find More Posts by waynemia
Reply With Quote
Old Aug 30, 2010, 11:37 AM
Walk of Shame Season :)
Waldopepperaxe's Avatar
NY
Joined Jun 2008
4,894 Posts
Wayne thats great I used to use Estes Rocket engines underneath my planes for some added speed boost lol back then I just used a servo and wired a 9 volt battery to set the ignighters off worked great but the switch system is much nicer, I'm also planning a surprize for my kadet at the club field either this Saturday or next Saturday depeneding on when I can get to the hobby store so it was funny to see the same idea to light the fuse just now,, what are the odds lol anyway it looked great I was thinking maybe you could mount the smoker in a rocket tube and it should hold the heat nicely and not be as bulky. especially if you hot fuel proof the tube. but regardless thats awesome Good job.
Waldopepperaxe is offline Find More Posts by Waldopepperaxe
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion New Club Thread - Northern Beaches Soaring Club Psionic001 Australia 13 Sep 11, 2014 07:45 AM
Help! Tower SUper Saver Club la528it Hot Online Deals 9 Jan 10, 2010 05:48 PM
Discussion San Francisco Model Yacht Club's multi-club Swap Meet craig_c Dock Talk 17 Oct 13, 2009 02:28 AM