HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 23, 2004, 09:57 PM
2ManyHobbies2LittleTime
jswayze's Avatar
United States, OH, Hamilton
Joined Sep 2003
363 Posts
STV5730a OSD Chip

Hi Folks,

I recently picked up an old project and, finding myself as stuck as I was when I dropped it, thought I'd put out a call for some assistance. I acquired an STV5730a video overlay chip from a fellow in Australia, soldered it to a DIP carrier and built up a circuit I found on the net. I also programmed a control program (also from the net) onto a PIC 16f628 and am using that to drive the STV5730a.

My goal is to make a GPS overlay for RC and karting applications, but for now I just want to get the darned thing to work. I know I can buy a pre-built board for $100, but after getting all the components, I can't bring myself to give up. My problem with the circuit is that I see video come through occasionally, but it usually fades rapidly, then it's back to the standard "rolling staggerd lines"... It looks like I'm having some sort of timing issue, but I just don't know enough about this stuff to diagnose it.

I'm not looking for specific troubleshooting help (though I'm all ears if you have anything to offer) but if someone has a tried and tested circuit they could pass along I'd be oh so grateful. So far I've tried the circuits from D. Jones ("(c)1999 Tronnort") and Robin Adams (www.adams-online.de/lcd). I've also referenced the circuit in the SGS-Thompson "STV5730a Quick Evaluation Guide" document. As I said before, I've got the chip on a carrier board and I'm mounting everything on a breadboard.

Thanks in advance - any inside would be greatly appreciated!

-Jeff
jswayze is offline Find More Posts by jswayze
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 25, 2004, 03:03 AM
Registered User
Mr.RC-CAM's Avatar
USA
Joined Oct 2001
5,188 Posts
Quote:
My problem with the circuit is that I see video come through occasionally, but it usually fades rapidly, then it's back to the standard "rolling staggerd lines"...
I assume you are using it in the overlay mode. When you say that you see video occassionally, do you mean the incoming video or the overlay video?

The app note's circuitry should be fine. I suspect that you have wiring errors or have a layout that is not appropriate for the fast clocks that are used. You should treat most of the I/O as if it was RF signals (short leads, good grounds, careful layout). But not to worry -- a breadboarded STV5730 can work just fine.

RC-CAM
Mr.RC-CAM is offline Find More Posts by Mr.RC-CAM
Reply With Quote
Reply


Thread Tools