HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Today, 04:56 AM
Registered User
Joined Jan 2015
36 Posts
Quote:
Originally Posted by RCSwed View Post
I bought a defect hubsan ditt cheap at an internet auction. It turned out that the connectors had come loose from inside the motor. Has anyone any ideas can I shove the connector back in the motor? Can I open it up? I can an will buy a new motor but it will take some weeks to get it delivered. Any ideas anyone?
Motors fubar
eman29 is offline Find More Posts by eman29
Reply With Quote
Sign up now
to remove ads between posts
Old Today, 05:00 AM
Registered User
Joined Jan 2015
36 Posts
Quote:
Originally Posted by benedikt View Post
The clear props are great. Well balanced, and very durable. Performance as stock.
The 3-leafers suck. Very easy to damage, very inefficient. But small and quiet.
I'll vouch for that, the clear props are the best I've used. Stock performance and flight time, but much more durable
eman29 is offline Find More Posts by eman29
Reply With Quote
Old Today, 05:30 AM
Registered User
Australia, QLD, Gold Coast
Joined Dec 2014
10 Posts
I received my hubsan x4 on Wednesday and set it up with the prop guard and tape mod charged the battery and flew it around the house and outside, I had two flights before I decided to redo the tape as it was lifting, I promptly ripped a motor out while removing a prop. Went to the study and ordered a set of 14k rpm motors from micromotorwarehouse.Com and they arrived Friday so I installed them Friday night!I put a drop of glue on the side of each motor where they stick out of the frame to avoid a repeat of the problem. My 500mah batteries also arrived Friday so I've been flying a bit since.

I have managed to crack the frame around one of the motors but it's not bad, must have been unlucky I've had some big crashes but nothing too serious.
I think I might have a loose wire or something in the quad because if I crash hard the lights start flashing like the battery is low and I have to turn it off and the tx and turn them both back on. Also if I squeeze the body the front left led goes out...

Any ideas? I'm away from home and only on mobile so searching isn't very easy. I will disassemble it Tuesday and check for bad joints if nobody else has any information on this being a known fault.

Shout out to benedikt at mmwh for the quick service and awesome motors. I need to compare with my friend who has a stock x4 but it definitely feels faster!
teracis is online now Find More Posts by teracis
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion The Hubsan X4 youxif Multirotor Talk 82 Jan 27, 2015 04:15 PM
Discussion Hubsan x4 6axis scousethief Mini Multirotors 295 Jun 21, 2013 08:22 AM
Discussion Hubsan X4 Mini Quad dc9guy Mini Multirotors 32 Feb 04, 2013 11:14 PM
Discussion Hitec X4-80 eighty 4 port chager review search Timewarp Batteries and Chargers 4 Jun 22, 2012 05:20 PM