SMALL - Telemetry SMALL - Radio
Thread Tools
Old May 09, 2015, 01:16 PM
sirlordwhitman is offline
Find More Posts by sirlordwhitman
Registered User
sirlordwhitman's Avatar
Joined May 2015
36 Posts
Discussion
Help with my DH 100 Vampire

My Vamp is assembled. But problems galore. I've plugged all the marked wires into my HK6S RX to the corresponding channels. I'm also using the HK6S radio. Of course, they are just marked 1-6, so I used the numbers on the wires respectively for each slot. The ESC keeps beeping at me.. slow beeps, then fast beeps. All I'm getting is ailerons and steering (with the retracts stowed). No elevator, no gear extension, and eventually I get throttle, but it goes full blast and there's nothing I can do to stop it, short of disconnecting the lipo. I did the binding process down to the letter (on one vague sheet of instructions).. only thing is that my TX does not have a bind switch. All I had to do was power it on, and it binded. But now all this weird crap is happening..
update : now I can't even get throttle. (((
sirlordwhitman is offline Find More Posts by sirlordwhitman
Reply With Quote
Sign up now
to remove ads between posts
Old May 09, 2015, 01:31 PM
timmybeetle is offline
Find More Posts by timmybeetle
No Guts, No Glory
timmybeetle's Avatar
Nederland, LI, Helden
Joined Sep 2010
672 Posts
Hk6s

Quote:
Originally Posted by sirlordwhitman View Post
My Vamp is assembled. But problems galore. I've plugged all the marked wires into my HK6S RX to the corresponding channels. I'm also using the HK6S radio. Of course, they are just marked 1-6, so I used the numbers on the wires respectively for each slot. The ESC keeps beeping at me.. slow beeps, then fast beeps. All I'm getting is ailerons and steering (with the retracts stowed). No elevator, no gear extension, and eventually I get throttle, but it goes full blast and there's nothing I can do to stop it, short of disconnecting the lipo. I did the binding process down to the letter (on one vague sheet of instructions).. only thing is that my TX does not have a bind switch. All I had to do was power it on, and it binded. But now all this weird crap is happening..
update : now I can't even get throttle. (((
Hi

I found this at HK

1) plug bind plug(in "id set" position)
2) turn on the reciever(plug esc/ubec/battery)
3) turn on the transmitter
4) wait a few seconds(10 must be enough)
5) unplug the bind plug
6) turn of the reciever
7) turn on the

reciever again and put a servo to test it If it works then you are done. If it doesn't work repeat the steps.

http://www.hobbyking.com/hobbyking/s...x_Mode_2_.html

are you having a mode 2??? xmtr??????

Good luck then

grts Hans
timmybeetle is offline Find More Posts by timmybeetle
Reply With Quote
Old May 09, 2015, 10:12 PM
sirlordwhitman is offline
Find More Posts by sirlordwhitman
Registered User
sirlordwhitman's Avatar
Joined May 2015
36 Posts
More Updates

Quote:
Originally Posted by timmybeetle View Post
Hi

I found this at HK

1) plug bind plug(in "id set" position)
2) turn on the reciever(plug esc/ubec/battery)
3) turn on the transmitter
4) wait a few seconds(10 must be enough)
5) unplug the bind plug
6) turn of the reciever
7) turn on the

reciever again and put a servo to test it If it works then you are done. If it doesn't work repeat the steps.

http://www.hobbyking.com/hobbyking/s...x_Mode_2_.html

are you having a mode 2??? xmtr??????

Good luck then

grts Hans
Hello! Thanks for your help. Incidentally, some of my connectors were wrong orientation, signal and ground not matching up. So now I get ailerons, elevator, retracts and nose-gear steering, but ABSOLUTELY no throttle. Hoping I didn't burn up the ESC. I am just wondering what channels 4 and 6 are supposed to be on the RX and if in fact they correspond to connectors 4and 6.
sirlordwhitman is offline Find More Posts by sirlordwhitman
Reply With Quote
Old May 10, 2015, 01:35 AM
timmybeetle is offline
Find More Posts by timmybeetle
No Guts, No Glory
timmybeetle's Avatar
Nederland, LI, Helden
Joined Sep 2010
672 Posts
Are you a newbe to rc???

Quote:
Originally Posted by sirlordwhitman View Post
Hello! Thanks for your help. Incidentally, some of my connectors were wrong orientation, signal and ground not matching up. So now I get ailerons, elevator, retracts and nose-gear steering, but ABSOLUTELY no throttle. Hoping I didn't burn up the ESC. I am just wondering what channels 4 and 6 are supposed to be on the RX and if in fact they correspond to connectors 4and 6.
Hi

If you are new in this hobby you have to be reading stuff about rc hobby all yours free time?????
Rcvr: normaly!!! (MODE 2)

1. Ailerons
2.Elevator
3.Motor/ESC
4.Rudder
5.Gear
6.Flaps

servo wire Brown/Black is minus Red is plus, Orange/White is signal.

Some ESC need throttle calibration first time you hook them up.
XMTR on, Throttle to full, arm RCVR/Plane wait for (normaly) 2 beeps and then throttle to zero.....

Also I can advise to go to a flying RC club there are pilots who can help you with all yours questions and you will have a lot.
If you never have flown an airplane before this one, you will need glue and money for spare parts too.

grts Hans
timmybeetle is offline Find More Posts by timmybeetle
Reply With Quote
Old May 10, 2015, 10:08 AM
Thomas B is offline
Find More Posts by Thomas B
Electric Coolhunter
Thomas B's Avatar
United States, TX, Fort Worth
Joined Jun 2000
14,893 Posts
Try taking your throttle trim to the lowest possible position. Some ESCs will not arm until they see a low enough throttle signal.
Thomas B is offline Find More Posts by Thomas B
RCG Plus Member
Latest blog entry: 2014 events and travel
Reply With Quote
Old May 10, 2015, 10:23 AM
timmybeetle is offline
Find More Posts by timmybeetle
No Guts, No Glory
timmybeetle's Avatar
Nederland, LI, Helden
Joined Sep 2010
672 Posts
Stock Setup ESC

Quote:
Originally Posted by Thomas B View Post
Try taking your throttle trim to the lowest possible position. Some ESCs will not arm until they see a low enough throttle signal.
Hi

Yes you are right about some ESC have to have throttle to minimum.
I know Eflite 30 A esc need that.
But if he is using stock Vampire from HK that ESC need to be calibrated as I described
How do I know.... I have one myself

grts Hans
timmybeetle is offline Find More Posts by timmybeetle
Last edited by timmybeetle; May 10, 2015 at 12:19 PM. Reason: add esc manual
Reply With Quote
Old May 10, 2015, 11:20 AM
Thomas B is offline
Find More Posts by Thomas B
Electric Coolhunter
Thomas B's Avatar
United States, TX, Fort Worth
Joined Jun 2000
14,893 Posts
Quote:
Originally Posted by timmybeetle View Post
Hi

Yes you are right about some ESC have to have throttle to minimum.
I know Eflite 30 A esc need that.
But if he is using stock Vampire from HK that ESC need to be calibrated as I described
How do I know.... I have one myself

grts Hans
Correct, but you cannot calibrate the ESC until it sees a valid throttle signal that is low enough to initially arm the ESC. I also own and fly this model.

First things first.
Thomas B is offline Find More Posts by Thomas B
RCG Plus Member
Latest blog entry: 2014 events and travel
Reply With Quote
Old May 10, 2015, 10:18 PM
sirlordwhitman is offline
Find More Posts by sirlordwhitman
Registered User
sirlordwhitman's Avatar
Joined May 2015
36 Posts
Quote:
Originally Posted by timmybeetle View Post
Hi

If you are new in this hobby you have to be reading stuff about rc hobby all yours free time?????
Rcvr: normaly!!! (MODE 2)

1. Ailerons
2.Elevator
3.Motor/ESC
4.Rudder
5.Gear
6.Flaps

servo wire Brown/Black is minus Red is plus, Orange/White is signal.

Some ESC need throttle calibration first time you hook them up.
XMTR on, Throttle to full, arm RCVR/Plane wait for (normaly) 2 beeps and then throttle to zero.....

Also I can advise to go to a flying RC club there are pilots who can help you with all yours questions and you will have a lot.
If you never have flown an airplane before this one, you will need glue and money for spare parts too.

grts Hans
Thanks for your Mode 2 information. That helps, and yes I am new to this hobby as of January. But anything I'm really interested in, I have OCD so I am a quick learner. I am now quite proficient with all of my trainers ( includes Cub and HZ Champ, and Flyzone P-38) and all of those aircraft have EXCELLENT documentation. The documentation that comes with the Vampire is absolutely HORRIBLE, and one would really have to rely on forums like this to figure out how to properly set up this aircraft. I also have an AMA instructor as a next door neighbor who flies gas powered turbines and EDFs and even he had a hard time figuring out my wires.

As for your mode 2 configuration, I made sure everything was plugged in correctly. With the ESC/BEC being on channel 3, I started over with bind plug. Powered on RX, saw it flash. Turned on TX, flash disappeared. Pulled bind plug, and ESC made series of beeps and a descending beep and it never stops. Went full up stick and it beeped twice. Went back down with stick and beeping stopped. But that was it. Absolutely no throttle. What's interesting to note, is that with each beep, the fan blades twitch.
sirlordwhitman is offline Find More Posts by sirlordwhitman
Last edited by sirlordwhitman; May 10, 2015 at 10:58 PM.
Reply With Quote
Old May 11, 2015, 10:01 AM
Thomas B is offline
Find More Posts by Thomas B
Electric Coolhunter
Thomas B's Avatar
United States, TX, Fort Worth
Joined Jun 2000
14,893 Posts
Did you try low throttle and full low throttle trim to get the ESC to arm?
Thomas B is offline Find More Posts by Thomas B
RCG Plus Member
Latest blog entry: 2014 events and travel
Reply With Quote
Old May 11, 2015, 07:48 PM
sirlordwhitman is offline
Find More Posts by sirlordwhitman
Registered User
sirlordwhitman's Avatar
Joined May 2015
36 Posts
I tried everything. The descending beeps according to a PDF source on the ESC indicate that the channel is reversed. I tried reversing and this did not work either. It seems that it is in program mode, but in order to be in program mode, you have to start from high throttle. My stick is all the way down when I turn on the TX and it beeps non-stop. I ordered another 70mm unit with ESC from hobbyking .
sirlordwhitman is offline Find More Posts by sirlordwhitman
Reply With Quote
Old May 12, 2015, 12:25 AM
sirlordwhitman is offline
Find More Posts by sirlordwhitman
Registered User
sirlordwhitman's Avatar
Joined May 2015
36 Posts
WELL I Figured it out! How weird! I went on Youtube and witnessed a guy disconnecting the three wires that go to the fan unit. With the transmitter on and on full throttle, the ESC is plugged into the battery. After a few seconds, the stick is lowered and the TX switched off. The wires are hooked back up to the EDF and the ESC powered back on. Well at this point, the throttle should work as normal but no. It started beeping at me again. So I tried binding it again, yet one more time. Nothing. So I bound it with the throttle in up position and as soon as I pulled the bind plug, the ESC made a happy noise I never heard before. SWISSSSZZHHHH!!!!! The EDF starts roaring but I couldn't stop it. I abruptly pull the battery from the ESC. Why can't I control it?? Maybe if I reverse my throttle?? So lo and behold. I switch my TX on plug the battery in with reverse throttle - happy chime. Up with the throttle and it works. Thanks everyone for steering me in the right direction!
sirlordwhitman is offline Find More Posts by sirlordwhitman
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log DeHavilland DH 100 Vampire 90mm Composite Assembly, mods, and set ups Piper down 7878 Electric Ducted Fan Jet Talk 2 Apr 10, 2015 10:44 AM
Sold HK dh-100 Vampire Retracts ltrfred Aircraft - General - Miscellaneous (FS/W) 3 Oct 17, 2013 07:19 AM
Sold RC Factoy De Havilland DH 100 Vampire EDF with GWS fan New $60 shipped USPS CONUS be69ar Aircraft - Electric - Airplanes (FS/W) 4 Dec 14, 2009 01:23 PM
Sold RC Factory De Havilland DH 100 Vampire kit with GWS EDF be69ar Aircraft - Electric - Jets (FS/W) 3 Dec 14, 2009 01:22 PM
Build Log Dh-100 Vampire Pss Build Finished with maiden vid r/c junkie Slope 172 May 01, 2009 05:39 PM