SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Dec 15, 2006, 01:33 PM
Registered User
whiteboyrabalac's Avatar
Joined Oct 2005
55 Posts
Help!
Jato 3.3

Got a used jato 3.3 today, put fuel in it and it wont start. Fuel is flowing in the lines but its not starting. Its also not being turning over with the usual rythm, its sorta sputterin.
whiteboyrabalac is offline Find More Posts by whiteboyrabalac
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 15, 2006, 01:55 PM
Ninja of the Nasty
KingOfTheHill's Avatar
Joined Jan 2004
10,642 Posts
Check the obvious first..

Glow plug
you have fuel..
Check your needle settings
Check your Throttle stop
pull the plug and crank it over a few times to make sure your not flooded
try a hand held ignitor insted of the "Wand"

give that a shot and post results...

JOe
KingOfTheHill is offline Find More Posts by KingOfTheHill
Reply With Quote
Old Dec 15, 2006, 02:20 PM
Registered User
whiteboyrabalac's Avatar
Joined Oct 2005
55 Posts
the glow plug light doesnt come on in the wand
whiteboyrabalac is offline Find More Posts by whiteboyrabalac
Reply With Quote
Old Dec 15, 2006, 02:46 PM
Registered User
in my shop...
Joined Apr 2005
83 Posts
well then your glow plug is DED u can probally pick one up at ur lhs.
bouncy-boy is offline Find More Posts by bouncy-boy
Reply With Quote
Old Dec 19, 2006, 03:26 PM
jato baby!!!
antonio-007's Avatar
Joined Mar 2006
210 Posts
have you fixed this problem dude??

your glow plug is either dead, or you havent got he wire connected to the glowplug (you should cut the connector off and solder a crocodile clip on, its easier to use and much better conduction)

OH! also check the roll bar connections. i.e the part that the ezstart goes in. lots of people i have heard have this problem were the wires come loose. undo the two hex screws each side of it and check there is no loose wires <has happened to friends when he rolled it

antonio
antonio-007 is offline Find More Posts by antonio-007
Reply With Quote
Old Dec 19, 2006, 08:09 PM
Registered User
whiteboyrabalac's Avatar
Joined Oct 2005
55 Posts
yeah i changed the plug, but now when i start it, it cuts out as soon as i put on any throttle, it did one run okay then stopped
whiteboyrabalac is offline Find More Posts by whiteboyrabalac
Reply With Quote
Old Dec 20, 2006, 06:47 AM
jato baby!!!
antonio-007's Avatar
Joined Mar 2006
210 Posts
-mine does that when its started up... i let it warm up for about 30 seconds and then feather the throttle for another 30.
if its doing it after about 30 seconds then your tuning is out bud.

-or it could need tuning to cope with the new plug, which may opperate differently

-high speed needle is not in tune when its cold, but when its hot it should sound brilliant!
(also go like jet assisted take-off )

antonio
antonio-007 is offline Find More Posts by antonio-007
Reply With Quote
Old Dec 23, 2006, 05:50 PM
Registered User
Joined Dec 2006
8 Posts
Sounds like the carb may be gummed up with old fuel. Take it off and clean it with some new fuel, remove the needles and use a dry air source to blow out the ports, like use computer air duster or the like. Set the carb high and low speed up rich to begin with and fine tune it after you can keep it running.

Engine have good compression? Hard to spin by hand? If it spins easy then the engine is weak, and needs rebuild.

Most Traxxas Nitro stuff that is bought used that I get near are already gutted and the owners are buying new engines.
Hayseed is offline Find More Posts by Hayseed
Reply With Quote
Old Dec 24, 2006, 11:41 PM
Registered User
whiteboyrabalac's Avatar
Joined Oct 2005
55 Posts
Hey guys got it running, it was the glow plug, anyway its on a breake, a lightning storm fried my charger(yes dumb me left it plugged in). It runs awesome though crashed into my 6 year old cousin at like 50, hes okay though, pretty banged up.
Thanks for the help
whiteboyrabalac is offline Find More Posts by whiteboyrabalac
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question jato 3.3 ?? bentech Nitro and Glow Power Cars 18 Jun 06, 2008 07:47 AM
Discussion Jato 3.3 whiteboyrabalac Nitro and Glow Power Cars 7 May 12, 2008 03:45 PM
Discussion Jato 3.3 MikeEstep Off-road Cars 10 Apr 30, 2008 09:55 PM
Discussion Jato 3.3 Tires EdgeCrusher Off-road Cars 8 Apr 06, 2008 12:32 PM
For Sale Jato 3.3 w/ Hitec Aggressor and Spektrum lcyrace Cars - Cars and Parts (FS/W) 2 Aug 10, 2006 11:47 PM