HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 28, 2012, 02:26 PM
Registered User
josereyes's Avatar
United States, WA, Steilacoom
Joined Nov 2011
162 Posts
Quote:
Originally Posted by JayNZ View Post
Thanks jan.

Ive put up pictures on the apache build page: http://www.rcgroups.com/forums/showt...1634181&page=2

Ive assembled the gun and added detail wiring, worked out linkage rod length and placement and connected it to the receiver. all works perfectly. Ill complete the installation once its all painted and rivited, and the apache mechanics are installed. i can already tell i will have a lot more room in my fuse now because of getting rid of my design for gun movement.
It's been a little over three weeks and still no 5 blade set of the flat black scale spinblades on the mail. They were shipped August 6 and as of August 28 they still have not arrived. I giving the benefit of the dought as they do have to go through customs... If by the end of the month I still have no blades I will be putting a claim through paypal... this is crazy
josereyes is offline Find More Posts by josereyes
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 28, 2012, 04:00 PM
CW4
Registered User
Joined Aug 2012
69 Posts
My 4-blade set shipped on Aug 13. At least I hope they did. I am going to give them a month.

In other news, I received both my tail pitch arm from microhelis.de last Friday and my CopterX 4-blade head from ehirobo yesterday. Both took about 3 weeks to get here from when I ordered them.

I am pretty impressed that for $117USD (that includes shipping) I got the 4-blade rotor head, a swash plate, main shaft and collar, swash follower and links. I was just expecting the head by itself!
CW4 is offline Find More Posts by CW4
Reply With Quote
Old Aug 28, 2012, 04:21 PM
Registered User
Horseman's Avatar
The Netherlands, FR
Joined Aug 2008
627 Posts
Quote:
Originally Posted by CW4 View Post
My 4-blade set shipped on Aug 13. At least I hope they did. I am going to give them a month.

In other news, I received both my tail pitch arm from microhelis.de last Friday and my CopterX 4-blade head from ehirobo yesterday. Both took about 3 weeks to get here from when I ordered them.

I am pretty impressed that for $117USD (that includes shipping) I got the 4-blade rotor head, a swash plate, main shaft and collar, swash follower and links. I was just expecting the head by itself!
Yes its a great head but please check the nylon boll-inks they were to hard and snapped when I try to put them on the threaded rods so I replaced them with Align boll-inks and problem solved.
I have send Hirobo a note at that time and they respond within 24 hours that they take action regarding this, so maybe no worries at all.
Its a real nice head and I will order the same for my BlackHawk.

Just my two cents,

Jan,
Horseman is offline Find More Posts by Horseman
Reply With Quote
Old Aug 28, 2012, 04:40 PM
Registered User
Joined Mar 2012
222 Posts
Quote:
Originally Posted by josereyes View Post
It's been a little over three weeks and still no 5 blade set of the flat black scale spinblades on the mail. They were shipped August 6 and as of August 28 they still have not arrived. I giving the benefit of the dought as they do have to go through customs... If by the end of the month I still have no blades I will be putting a claim through paypal... this is crazy
Hi jose, My 5 blades turned up yesterday. possibly just still in transit but you will be well within your rights but when you agree to the terms and conditions it states they are not liable for loss of goods or damage caused during transit. their packaging is a little poor to say the least so i hope the latter isnt the cause of the delay.
JayNZ is offline Find More Posts by JayNZ
Reply With Quote
Old Aug 28, 2012, 04:48 PM
Registered User
josereyes's Avatar
United States, WA, Steilacoom
Joined Nov 2011
162 Posts
Quote:
Originally Posted by JayNZ View Post
Hi jose, My 5 blades turned up yesterday. possibly just still in transit but you will be well within your rights but when you agree to the terms and conditions it states they are not liable for loss of goods or damage caused during transit. their packaging is a little poor to say the least so i hope the latter isnt the cause of the delay.

I will give them more time. Yes, I have a feeling they're stuck in customs... as when I ordered from China and Japan it does take a bit longer. However, when I ordered from microhelis.de it used to arrive within 3 weeks... I have ordered many parts from microhelis and always had a great experience with them...

I figure if they don't get here by the end of August, I will install the Copter X head back on so I can do some flying before it gets nasty in Washington State with the fall/winter weather The Copter X is a great head for the price and almost undestructible... Mine flew fine with it other than a minor wobble here and there wen flying in gusty winds other than that awesome head...

So by this weekend If no spinblades I will put the copter x head back on... I am currently wating on some seats from Century Heli in Germany for my copckpit and some led's for the cockpti, when they arrive I will be installing it on my MD500 very nice cockpit by the way...
josereyes is offline Find More Posts by josereyes
Reply With Quote
Old Aug 28, 2012, 05:06 PM
CW4
Registered User
Joined Aug 2012
69 Posts
Quote:
Originally Posted by Horseman View Post
Yes its a great head but please check the nylon boll-inks they were to hard and snapped when I try to put them on the threaded rods so I replaced them with Align boll-inks and problem solved.
I have send Hirobo a note at that time and they respond within 24 hours that they take action regarding this, so maybe no worries at all.
Its a real nice head and I will order the same for my BlackHawk.

Just my two cents,

Jan,
Thanks for the heads-up. I will take close look at the links. I am just about ready to start building the mechanics. I hope to test fly them within the next 2 weeks or so.

If I remember correctly, you are using a Helicommand stabilization system on your Apache, is that right?

Patrick
CW4 is offline Find More Posts by CW4
Reply With Quote
Old Aug 29, 2012, 06:21 AM
Registered User
Horseman's Avatar
The Netherlands, FR
Joined Aug 2008
627 Posts
[QUOTE=

If I remember correctly, you are using a Helicommand stabilization system on your Apache, is that right?

Patrick[/QUOTE]

Yes and I'm very glad with it, I use it as a bailout unit so normally its off (except the FBL stabilization the so called Rigid) and when I lose sight / orientation I flip the switch and the horizontal stabilization kicks in and saves the day
It did it already ones.
I have three of them now, two Rigid and two 3A units.
One 3A is laying there and the others in function.

They give (as I speak for myself) me piece off mind wile flying I do not need them but I can use it.

Jan,
Horseman is offline Find More Posts by Horseman
Reply With Quote
Old Aug 29, 2012, 06:26 AM
Registered User
Joined Mar 2012
222 Posts
well i had a fly with my hughes 600 size with 5 blade head and new spinblades. I have to say, im usually bang on with setting all my blades to 0 degrees, but i just cannot get the blades tracking correctly. at 50% throttle there should be perfect tracking, but ive got quite a bit difference in blades tip heights when theyre spinning. The blades cant be balanced.

when they came in the box they came with 2 blades in one parcel, and 3 blades in the other, so i assumed these blades may have weight differences so i installed the 3 blades next to each other, then the remaining two in the remaining grips. this is the same as when you have diffrent weighted blades on a 4 blade head and balance them by putting two of the same weight blades opposing each other to balance out the disk.

borrowing a friends micro scales and will weight them all out. if they are all different weights i will be complaining and requesting replacements. unfortunately spinblades suck when it comes to replying to emails.
JayNZ is offline Find More Posts by JayNZ
Reply With Quote
Old Aug 31, 2012, 02:00 PM
Registered User
josereyes's Avatar
United States, WA, Steilacoom
Joined Nov 2011
162 Posts
Quote:
Originally Posted by josereyes View Post
I will give them more time. Yes, I have a feeling they're stuck in customs... as when I ordered from China and Japan it does take a bit longer. However, when I ordered from microhelis.de it used to arrive within 3 weeks... I have ordered many parts from microhelis and always had a great experience with them...

I figure if they don't get here by the end of August, I will install the Copter X head back on so I can do some flying before it gets nasty in Washington State with the fall/winter weather The Copter X is a great head for the price and almost undestructible... Mine flew fine with it other than a minor wobble here and there wen flying in gusty winds other than that awesome head...

So by this weekend If no spinblades I will put the copter x head back on... I am currently wating on some seats from Century Heli in Germany for my copckpit and some led's for the cockpti, when they arrive I will be installing it on my MD500 very nice cockpit by the way...
Blades are in They were packed very good... mounted the blades on my heli, I have only been able to do a hover test. It hovered nicely, but I have to check it out on fast forward. Will post results when I get a chance to go a fly it...
josereyes is offline Find More Posts by josereyes
Reply With Quote
Old Sep 01, 2012, 09:12 PM
Registered User
Joined Mar 2012
222 Posts
Hi guys,

Jose, thats awesome. i reckon the delay must have been US customs going overboard because the packaging said "blades" on it? haha

ive just flown my blackhawk, (not much just low hover, slow forward and turns)after installing the replacement parts from RCA and mounting the 700 size main blades. tracking is fine, no more cyclic wobble, mechanics arte solid after 4 15 minute test flys yesterday, kin is bang on right about thosetfmodel infused blades, they must be too soft. couldnt lift my UH-60 at its current weight, which i estimate to be up around the 5.5kg mark.






unfortunately, i cannot get my tail to hold. its constantly over correcting, even when im not inputting any rudder, it will sway from left to right. When i set the beast x to rate mode, my geometry is fine, no tail sway, it just sits where i tell it to, unless some wind/ground turbulence is present. i can crank my gyro gain all the way up to 65, and it irons out the wobble in hover and forward flight but blows out on the turns and then fishtails.

it flew absolutely fine in pod and boom yesterday, i was cranking it, full pirouettes and the tail was perfect. it would stop perfectly on a right turn, and on a left turn it would stop, but not as precisely as when turning right, swaying back towards the right when it stopped just slightly.


i do not like the mutli blade tail rotor i am using, i thought i was getting the same model as on my apache but i was sent something different. One minute it feels finek the next it feels like its very sticky and feels like it wants to bind when pushed and pulled towards its endpoints. the center is the only smooth area of travel. it did not do this before, and the only thing ive changed is the angle tail drive. it seems like its feeding back now, but theres no part of the control arms rubbing on the fuse at any stage as far as i can tell.

If anyone could share some wisdom and experience with me id be highly appreciative.

tight turns!
JayNZ is offline Find More Posts by JayNZ
Reply With Quote
Old Sep 01, 2012, 10:56 PM
Registered User
josereyes's Avatar
United States, WA, Steilacoom
Joined Nov 2011
162 Posts
Quote:
Originally Posted by JayNZ View Post
Hi guys,

Jose, thats awesome. i reckon the delay must have been US customs going overboard because the packaging said "blades" on it? haha

ive just flown my blackhawk, (not much just low hover, slow forward and turns)after installing the replacement parts from RCA and mounting the 700 size main blades. tracking is fine, no more cyclic wobble, mechanics arte solid after 4 15 minute test flys yesterday, kin is bang on right about thosetfmodel infused blades, they must be too soft. couldnt lift my UH-60 at its current weight, which i estimate to be up around the 5.5kg mark.






unfortunately, i cannot get my tail to hold. its constantly over correcting, even when im not inputting any rudder, it will sway from left to right. When i set the beast x to rate mode, my geometry is fine, no tail sway, it just sits where i tell it to, unless some wind/ground turbulence is present. i can crank my gyro gain all the way up to 65, and it irons out the wobble in hover and forward flight but blows out on the turns and then fishtails.

it flew absolutely fine in pod and boom yesterday, i was cranking it, full pirouettes and the tail was perfect. it would stop perfectly on a right turn, and on a left turn it would stop, but not as precisely as when turning right, swaying back towards the right when it stopped just slightly.


i do not like the mutli blade tail rotor i am using, i thought i was getting the same model as on my apache but i was sent something different. One minute it feels finek the next it feels like its very sticky and feels like it wants to bind when pushed and pulled towards its endpoints. the center is the only smooth area of travel. it did not do this before, and the only thing ive changed is the angle tail drive. it seems like its feeding back now, but theres no part of the control arms rubbing on the fuse at any stage as far as i can tell.

If anyone could share some wisdom and experience with me id be highly appreciative.

tight turns!
65? Ijust had to increase my gain to 78 on my 600 MD500 because the 5 blades were putting more torque out and the tail was feeling loose. Also had to increase my head speed. I'm currently using 1450, 1500, 1550
josereyes is offline Find More Posts by josereyes
Reply With Quote
Old Sep 02, 2012, 02:50 AM
Registered User
Joined Mar 2012
222 Posts
hmm, see my hughes 500e 600 size is fine, the tail is perfect, no adjustment needed. my hughes headspeed is 1600.

for the uh-60, ill try increasing both the gyro gain (on my dx8) and throttle curve when i get to the airfield next. its a shame because its spring here now and the SW wind has kicked in right on cue, so i cant see myself getting a decent day for a while.

cheers,
JayNZ is offline Find More Posts by JayNZ
Reply With Quote
Old Sep 02, 2012, 02:42 PM
Registered User
Horseman's Avatar
The Netherlands, FR
Joined Aug 2008
627 Posts
Hi Jay,

Are those blade 700 size spinblades? they look a bit small compare to the length but how longer I look at your blades the more I start to like them and they looking awesome on that big bird

Jan,
Horseman is offline Find More Posts by Horseman
Last edited by Horseman; Sep 02, 2012 at 02:45 PM. Reason: hard to tell it sometimes in English
Reply With Quote
Old Sep 02, 2012, 03:25 PM
Love my scale Whirlybirds
Keyrigger's Avatar
Mississauga, Ont., Can.
Joined Sep 2009
2,442 Posts
JayNZ, that heli looks great. Hope you get the tail overcompensation sorted out. Take care.

Don
Keyrigger is offline Find More Posts by Keyrigger
Reply With Quote
Old Sep 02, 2012, 03:38 PM
Registered User
Leopoldsburg, Belgium
Joined Jul 2006
222 Posts
Jay,

When you set the gyro rate on the beast x, remember to look at the lights on the beast to see the % of gain you put in, not the number on your Tx..
Just a thought..

Didier
didier n is offline Find More Posts by didier n
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log RC Aerodyne 500-sized UH-60 Blackhawk Mike_Then Scale Helicopters 171 Sep 09, 2014 05:11 PM
Sold UK/EU - RC Aerodyne 500 size UH1N huey fuselage - rescue Cthulu Aircraft - Electric - Helis (FS/W) 6 Jul 14, 2012 07:23 AM
Build Log RC Aerodyne 600-sized Eurocopter Fennec AS-550 **COMPLETE!!** Mike_Then Scale Helicopters 31 Jan 02, 2012 11:22 AM
Sold 60 size UH-60 blackhawk fuse rcshirt Aircraft - Fuel - Helis (FS/W) 1 Jun 10, 2010 09:59 AM
For Sale Excellium 480 size UH-60 Blackhawk fuselage hagenuk Aircraft - Electric - Helis (FS/W) 2 Jan 25, 2010 10:40 AM