Shop our Airplanes Products Shop our Surface Products
Thread Tools
Old Sep 30, 2015, 12:11 PM
Hard Eddy is offline
Find More Posts by Hard Eddy
BAMF
Joined Jul 2015
9 Posts
Discussion
600tvl fatshark camera problem

I recently had my 600tvl fatshark camera go black screen on me mid flight. Not cool. After trying to diagnose the issue I found it to be a loose connection in the camera, not sure which one yet but when I tap on the camera the picture comes back until it is bumped again. I have used a different cable, transmitter and camera to figure out this is the issue. Is this a common issue and if so how do I fix it?
Hard Eddy is offline Find More Posts by Hard Eddy
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 30, 2015, 01:52 PM
AndyPG is offline
Find More Posts by AndyPG
Registered User
United Kingdom, Lincs
Joined May 2015
324 Posts
I've had a few problems with Fatshark CMOS cameras, both the 600TVL and the 700TVL. Its a shame because the 600TVL in particular is a great little camera.
My 600 suffers from a shakey image. A quick look inside revealed the PCB to be quite loose in the case so thought it would be an easy fix with a small piece of sponge in there to keep it pressed forward. No change so it can only be used in my Bixler as the small amount of vibration in my quad aggrovates it.
My 700TVL flickers every few seconds. I checked the little plug and spotted it was quite a loose fit and slides out easily. so I keep it pressed in with a small elastic band and this has cured it.
I would suggest trying a new plug.
AndyPG is offline Find More Posts by AndyPG
Reply With Quote
Old Sep 30, 2015, 07:24 PM
Hard Eddy is offline
Find More Posts by Hard Eddy
BAMF
Joined Jul 2015
9 Posts
Awesome, thank you! It is definitely not the plug, I tried wiggling it and what not but it does seem to be a bad connection inside. I will try the sponge trick, that seems to be the likely fix for my issue. I agree with you though, I have no complaints about fatshark products, things just happen sometimes. This camera is on my 300mm quadcopter and has a had a few tumbles so this was bound to happen at some point.
Hard Eddy is offline Find More Posts by Hard Eddy
Reply With Quote
Old Sep 30, 2015, 08:37 PM
Hard Eddy is offline
Find More Posts by Hard Eddy
BAMF
Joined Jul 2015
9 Posts
AndyPG, thank you very much you are a life saver.
I opened up the camera and the main board seemed a bit jiggly. I did not have a sponge to cut a piece from, instead I used a cut and rolled piece of the fabric wipe that the camera came with and put that in there. Works awsome! Thanks again.
Hard Eddy is offline Find More Posts by Hard Eddy
Reply With Quote
Old Oct 01, 2015, 04:01 PM
AndyPG is offline
Find More Posts by AndyPG
Registered User
United Kingdom, Lincs
Joined May 2015
324 Posts
Awesome... :-)
AndyPG is offline Find More Posts by AndyPG
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion 600tvl cctv camera problem tann200 FPV Equipment 4 Jun 19, 2015 01:50 AM
For Sale FatShark CMOS 600TVL Pan/Tilt Camera (FSV1206) bryanchodgson FPV Equipment (FS/W) 7 May 27, 2015 11:12 AM
For Sale FatShark CMOS 600TVL Pan/Tilt Camera (FSV1206) bryanchodgson Aircraft - Electric - Multirotor (FS/W) 1 Apr 26, 2015 12:18 PM
Discussion how did you mount your fatshark 600tvl camera? ummagawd FPV Equipment 20 Jan 22, 2015 01:11 PM
Wanted Fatshark FatShark Pilot HD v2 camera or 600TVL Camera. ShokWaveRider FPV Equipment (FS/W) 0 Dec 02, 2014 12:11 PM