SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Jun 21, 2013, 02:35 PM
Registered User
Tulsa Jones, Oklahoma, United States
Joined May 2002
315 Posts
Discussion
PH80 Problem

Have a PH80 hooked up to an Eflite power 32 with Zippy 40c 4000mah lipo.

When I throttle up, power comes up fine, but if I throttle back to idle and re-advance the throttle the motor barely ticks over. If I let the motor stop spinning completely and the prop stops, it will advance again with full power.

No bec in use.

The software is v4.05. Using auto calibration.

Can you give me any hints what's causing this.

I tried both of my PH80's and get same results.

Jeff
nxtdoor is offline Find More Posts by nxtdoor
Reply With Quote
Sign up now
to remove ads between posts
Old Jun 21, 2013, 04:22 PM
A man with too many toys
United States
Joined Feb 2001
17,623 Posts
Sounds like the new firmware is not 100% debugged. Try going back to the highest non-beta V3.xx firmware and see if that solves the problem.

Be sure and go to the download page and submit a bug report. That’s the way that CC knows they have a problem that they need to work on.

.
RC Man is online now Find More Posts by RC Man
Reply With Quote
Old Jun 25, 2013, 10:44 AM
Castle Support
Clintstone's Avatar
USA, GA, Statesboro
Joined Oct 2007
956 Posts
GO back to 4.02... there is a bug with 4.05 for some of the PH controllers. Like Mike said please fill out the bug report and return to 4.02... there will be a fix in the future. Thanks



Quote:
Originally Posted by nxtdoor View Post
Have a PH80 hooked up to an Eflite power 32 with Zippy 40c 4000mah lipo.

When I throttle up, power comes up fine, but if I throttle back to idle and re-advance the throttle the motor barely ticks over. If I let the motor stop spinning completely and the prop stops, it will advance again with full power.

No bec in use.

The software is v4.05. Using auto calibration.

Can you give me any hints what's causing this.

I tried both of my PH80's and get same results.

Jeff
Clintstone is offline Find More Posts by Clintstone
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion PH80 overheating? Atom1025 Castle Creations 0 Sep 24, 2007 07:48 PM
Sold LR-1 Pylon Racer & 22-30-02/PH80/Etc. Parallax Aircraft - Electric - Airplanes (FS/W) 0 Nov 11, 2005 12:58 PM
Can't get PH80 and Hacker B40LMR to start RicVaughn Castle Creations 1 Jul 04, 2004 05:33 PM
Question Battery to PH80 wire length? MikeF Castle Creations 2 May 14, 2004 10:57 AM
PH80 - won't restart when windmilling? habazot Castle Creations 2 Jan 07, 2004 01:14 PM