New Products Flash Sale
Thread Tools
Old Mar 13, 2015, 03:17 PM
boarderx is offline
Find More Posts by boarderx
Registered User
Joined Mar 2015
1 Posts
Need help with determining if I was sold a broken helicopter.

I think I was sold a used MCX2 instead of a new one. I'm totally new to the RC world, so bear with me. I bought a MCX2 last week and when I opened the box, the helicopter looked a bit used. There weren't any cracks or chips, but I always new purchases for fingerprints and saw a bunch of them on the rotors (yes, I'm obsessive and paranoid ). The tape holding the helicopter into the box wasn't very sticky. Also, the battery had a small piece of heat shrink tubing on it, down near the piece that goes into the charger (which I haven't seen on any MCX2 unboxing videos on YouTube).

I've flown with the model three times and I've noticed a few things. First, it doesn't fly forward very well. I hold the forward switch all the way and it moves about 1 ft per 1.5 seconds. It flies backwards a lot faster. I also notice that it doesn't rotate counter-clockwise as fast as it rotates clockwise (while hovering). I've seen videos where it can rotate in both directions at the same speed. One more thing that happened during my last flight was when I first turned on the helicopter and it connected to my radio, the helicopter motor was humming, like it was trying to run, but was stuck. The throttle was definitely off.

I bought a DX6i with the helicopter and set it up using @valiantGLX's settings found on the first page of this thread. I've flown with F Mode both on and off and moving forward acts the same in both.

I'm hoping a few of you can throw out some suggestions on things to check with either the radio or the model. I don't want to accuse the retailer (from eBay) of selling me a used helicopter if this is user error. I really don't know where to start since this is all new to me!
boarderx is offline Find More Posts by boarderx
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 13, 2015, 04:37 PM
North_of_49 is online now
Find More Posts by North_of_49
Scout CX | mCX2 | mSR | 120SR
North_of_49's Avatar
Canada, AB, Edmonton
Joined Dec 2011
8,560 Posts
boarderx,

Sounds like it might have been used... the heat shrink on the battery is not normal. There are a few reasons people use heat shrink on these batteries but the point is it's a user modification.

If it doesn't move forward very fast, check to see if the battery is hitting the servo gear on the heli's circuit board (the heat shrink could be a previous owner's attempt to prevent this. Also look for hair/lint around the little servo gear that could be making it bind.

Or a previous user may have given the elevator pushrod that goes from the servo to the swash a number of turns (which changes its length) leaving it with little forward movement. I've done this to mine for fast forward flight leaving almost no reverse, it would be odd for someone to set it up the opposite, though.

If it doesn't pirouette (which is a rudder action known as yaw) there could be a couple of causes, but first tell me does it sit still with no yaw (no spinning) when you're not on the rudder, and does it do that with little to no rudder trim on the radio (or does it need a lot of radio rudder trim to not spin with neutral rudder stick)?

The humming is probably a servo humming which is normal if it's quiet. If it's loud it could be binding (see what I said about the battery/hair/lint or anything else that might be jamming a servo gear. Or a servo gear might have a missing tooth, try spinning the little servo gears on the circuit board with your finger with the heli not powered and see if they feel free and smooth with no tight spots. This will move the servo pushrods, but they'll go back to the correct position next time the heli is powered up).
North_of_49 is online now Find More Posts by North_of_49
RCG Plus Member
Last edited by North_of_49; Mar 13, 2015 at 04:44 PM.
Reply With Quote
Old Mar 13, 2015, 05:52 PM
DoomsDay is offline
Find More Posts by DoomsDay
Registered User
DoomsDay's Avatar
Charlotte Douglas, NC
Joined Sep 2003
3,044 Posts
Also note, the 150 batteries that horizon put out a few years ago did have that heat shrink tubing on it, it was used as a spacer so you didnt push the battery in to far. I cant remember if that battery ever shipped with the mcx2 (I think it only shipped with the msr) but if it did, that would mean you could have a new mcx2 that has been sitting in a box for a few years. or the store owner switched out the battery at one point and put in the bigger battery.

The stock mcx2 has always spun slower in one direction than the other. The only time it was fast in both directions was if you were using the carbon fiber tail. As for flying speed, That speed sounds correct if the linkages on the swashplate are still setup for beginner. If you move them to advanced you should see a much more nimble little helicopter both in all aspects of flight and in pirouettes.
DoomsDay is offline Find More Posts by DoomsDay
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question BLADE MCX 2 Vibration issues valiantGLX Coaxial Helicopters 8 Mar 26, 2012 12:48 PM
Sold Spektrum DX6i w/Blade 400 3D, RTF HeliMax AXE CPV3...LOWERED PRICES!! ABADGTP Non R/C Items (FS/W) 7 Sep 22, 2011 09:58 PM
Data Dx6i mcx settings Stugoose Coaxial Helicopters 6 Sep 20, 2011 05:01 PM
Discussion BLADE MCX 2 Vibration issues valiantGLX Electric Heli Talk 0 Sep 11, 2011 03:33 PM
Discussion DX6I and Blade CX2, MCX Problems streek Multirotor Talk 2 Sep 11, 2011 03:17 PM