New Products Flash Sale
Thread Tools
Old Jan 13, 2016, 06:41 PM
addictedtoplanes is online now
Find More Posts by addictedtoplanes
and helis!
addictedtoplanes's Avatar
Canada, ON, Guelph
Joined Jun 2012
822 Posts
Question
Weird issue with CC3D

Back in November, I put together my first quad, an Emax 280 Pro, using a CC3D, and Openpilot. It flew fine for about a month, but after a while, I started noticing that it would have problems with certain batteries. With one of my Turnigy Nanotech 1300 3Ss, about 2 min into the flight, it would pitch forwards and to the left. I thought it might be a dead battery, but I tested it multiple times with different aircraft and had no issues. Recently, a second issue has cropped up while in Attitude/Rattidude mode. I arm it, and give it time for they gyro to initialize, but it will always pitch hard down after takeoff. If I hold aft on the stick, I can hold it level, and after around 30s-1min of flying, it goes away. If I land, and let the aircraft sit the problem returns. It only happens in Attitude/Rattitude mode, never in Rate mode. I am flying with the same stability settings that I started with. On occasion, it will pitch in different directions when in Attitude or Rattitude mode, but once again, it never does this in Rate mode. I have tested this while plugged into the Openpilot software, but even with the motors running, or in a low hover (I have a really long cable) I don't see anything. Is this a software issue, or is something actually wrong with the Gyro/Accelerometer on the CC3D, and should I just upgrade to something like a Naze32?
addictedtoplanes is online now Find More Posts by addictedtoplanes
Reply With Quote
Sign up now
to remove ads between posts


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Weird Motor Sync Issue With CW Motors redstars Multirotor Electronics 0 Sep 09, 2015 03:36 PM
Help! Naze32 with Neo-6M weird issue. spcrxj Multirotor Electronics 5 Aug 12, 2015 06:51 AM
Help! Need help with weird LED lighting issue on Phantom 1.1.1 FRUITLOOPS322 Multirotor Talk 5 Jun 22, 2015 07:38 PM
Discussion Help! Weird issue with FPV P/T/R with SAFE, Dual Receivers mbackus Electric Plane Talk 3 Mar 29, 2015 05:36 PM
Discussion issue with nano cpx - weird servo movement Chris Corbett Micro Helis 3 Jan 17, 2014 02:53 AM