HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 27, 2014, 11:28 AM
FunkMaster
EliteFunk's Avatar
Canada, BC, Penticton
Joined Jul 2014
15 Posts
Discussion
Pls help er9x/naze32 wont arm. going crazy

Hello, I recently installed smartieparts board into my tgy 9x running er9x firmware, and naze32 FC. I have everything set up how I think it should be, but the motors wont arm. In receiver tab in baseflight I can see all channels responding correctly and when I hit the gear switch for angle mode the red led on the FC turns on so I know its receiving but it wont arm. I have tried setting arm to different switches, didnt work. The only thing I can think of is when I start up TX after splash screen it tells me something like " throttle not idle press any key to ignore" however all my channles jitter a little bit it was like this with stock FW but it worked fine then. Is this why it wont arm and if so what can I do?
EliteFunk is offline Find More Posts by EliteFunk
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 27, 2014, 11:45 AM
Frequent Flyer
whitecrest's Avatar
Orleans, MA
Joined Feb 2007
2,104 Posts
The throttle must be at minimum before the motor will arm. Make sure throttle trim is also at minimum.
whitecrest is offline Find More Posts by whitecrest
Reply With Quote
Old Nov 27, 2014, 12:34 PM
FunkMaster
EliteFunk's Avatar
Canada, BC, Penticton
Joined Jul 2014
15 Posts
ok so turns out the stick assignments were all off, got that sorted properly, no longer getting throttle not idle after splash. however it still will not arm, end points and everything are good, though I notice in baseflight when I activate angle mode it turns green and the red led on the fc turns on, but when I hit the arm switch nothing happens the channel stays red in baseflight and no led change on FC, do I need to enable/disable some feature in baseflight cli?

thanks for the quick response btw
EliteFunk is offline Find More Posts by EliteFunk
Reply With Quote
Old Nov 27, 2014, 04:37 PM
FunkMaster
EliteFunk's Avatar
Canada, BC, Penticton
Joined Jul 2014
15 Posts
ok i got it working, had to tweak mincheck/maxcheck
EliteFunk is offline Find More Posts by EliteFunk
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Hobbyzone f4u s going crazy please help. Torchia32 Electric Warbirds 20 Nov 11, 2014 08:21 AM
Discussion naza m lite wont arm motors Please help hotdog1 Multirotor Electronics 34 Aug 26, 2014 04:44 AM
Discussion v120d02s is crazy..PLS HELP Xwalt 3D Fuel Heli Flying 0 Dec 06, 2013 01:52 AM
Discussion Mini camera help pls, wont stay on. Electricians. Gmike15 DIY Electronics 6 Aug 07, 2011 04:28 PM
Help! Servo arms going crazy!!! zoltarDO Coaxial Helicopters 4 Mar 29, 2008 12:56 PM