HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 01, 2009, 01:41 PM
Registered User
cornwall, uk
Joined Dec 2008
29 Posts
Discussion
Problem with my T28 trojan

been out flying every day for the last week as we have had good weather had about 15 flights no problems
i was flying today been up about 9 mins just getting ready to land and all of a sudden it just rolls right so i correct with left aileron and keep it level but this slows the plane right down so i figure my right aileron is jammed down manage to land it with the aid of a bush no damage anyway left aileron is jammed down so they acted like flaps i turned off the tx and turned it back on again and all was working fine so i put my other pack in flying it around no problems the again been up about 9 mins and same thing and luckily i landed it again no probs and same thing all seemed fine again im to scared to fly it now incase i crash it bad

any ideas why this is happening??
rosco28uk is offline Find More Posts by rosco28uk
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 01, 2009, 01:49 PM
Going broke, dam this hobby
xlrDALLAS's Avatar
cleveland oh
Joined Mar 2009
622 Posts
a bad servo maybe ?
xlrDALLAS is offline Find More Posts by xlrDALLAS
Reply With Quote
Old Apr 01, 2009, 02:06 PM
The building never ends!
Tucson, AZ
Joined Oct 2008
1,056 Posts
Definitely sounds like a bad servo.
Ensign Jimmy is offline Find More Posts by Ensign Jimmy
Reply With Quote
Old Apr 03, 2009, 04:01 PM
scotland uk
Joined Jan 2005
1,390 Posts
funny you should say that rosco.mine done the exact same last nite! but it was just after take off.
i landed on the wing.plane totally fkd!

2 weeks old.

50 worth of damage
wishawhunk is offline Find More Posts by wishawhunk
Reply With Quote
Old Apr 03, 2009, 04:38 PM
Flying high
billwhit's Avatar
Seattle, Wa
Joined Dec 2002
2,263 Posts
I've had the same problem. I have assumed it's the servo, but I haven't switched it out yet because with all my tests at home it seems ok. I haven't flown is again yet either, but will probably try a nice easy flight to see if it happens again. I hope you get it sorted out.

Out of curiosity, what servo are you using?
billwhit is offline Find More Posts by billwhit
Reply With Quote
Old Apr 03, 2009, 05:03 PM
scotland uk
Joined Jan 2005
1,390 Posts
im using the stock servo
wishawhunk is offline Find More Posts by wishawhunk
Reply With Quote
Old Apr 03, 2009, 09:30 PM
Registered User
cornwall, uk
Joined Dec 2008
29 Posts
i,m using the standard servo that came with it i have flown it since first battery no problems 2nd battery it jammed the right aileron down at about 100feet i managed to get it down to about 20 feet but it just stalled due to both ailerons being down went in nose first and it wrecked it, ripped the front right off and ripped the wing off, ive repaired it but want to find out why its doing it before i fly again
rosco28uk is offline Find More Posts by rosco28uk
Reply With Quote
Old Apr 04, 2009, 04:27 AM
scotland uk
Joined Jan 2005
1,390 Posts
ive just repaired mine also.don want to fly it now!

think i may invest in 2 new servos!

wishawhunk is offline Find More Posts by wishawhunk
Reply With Quote
Old Apr 06, 2009, 06:15 AM
scotland uk
Joined Jan 2005
1,390 Posts
rosoco i noticed you all posted this in a uk forum.im from scotland so you can imagine the weather we get lol.
i just flew my t-28 and it flew great.
i think my elevator was loose so i used white insulating tape to hold it down on to the fuselage.also make sure evrything on you plane is tight and secure.my problem is away for the mean time.hope it doesnt return.
just a thought for you perhaps

andy
wishawhunk is offline Find More Posts by wishawhunk
Reply With Quote
Old Apr 06, 2009, 08:14 AM
Registered User
cornwall, uk
Joined Dec 2008
29 Posts
Quote:
Originally Posted by wishawhunk
rosoco i noticed you all posted this in a uk forum.im from scotland so you can imagine the weather we get lol.
i just flew my t-28 and it flew great.
i think my elevator was loose so i used white insulating tape to hold it down on to the fuselage.also make sure evrything on you plane is tight and secure.my problem is away for the mean time.hope it doesnt return.
just a thought for you perhaps

andy

yeah good old weather in the uk your up the top end and im down the bottom in Cornwall i might fly it tmrw if the rain stops i have checked everything all seems ok did you replace your servos??
rosco28uk is offline Find More Posts by rosco28uk
Reply With Quote
Old Apr 06, 2009, 09:39 AM
scotland uk
Joined Jan 2005
1,390 Posts
didnt replace anything rosoco no.just maked sure everything was tight esp the elevator.make sure thats taped down good and stright.also make sure that the screw that attaches the wings to the fuselage is tight also

andy
wishawhunk is offline Find More Posts by wishawhunk
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Major glitching problem with my MiniMax using qualcomms on first flight! compuatic Parkflyers 3 Jul 03, 2002 08:59 AM
Got a problem with my astroflight 115d charger kushal_22 Foamies (Kits) 5 Apr 23, 2002 09:17 AM
I have a problem with my rotor head. ermit Electric Heli Talk 8 Apr 03, 2002 11:50 AM
Problem with my Exite mail tripster Aircraft - Electric - Airplanes (FS/W) 5 Dec 08, 2001 04:06 PM
Problem with my new Hitec Focus 3SSFM RCD markpsmith Electric Plane Talk 1 Aug 05, 2001 11:36 AM