HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Feb 19, 2012, 04:30 AM
Registered User
Joined Nov 2010
108 Posts
Help!
Firmware update error with OSD pro ONLY Data Logger and Gardian firmware update works

Hey guys I'm having a really frustrating problem with my OSD pro!!

I recently crashed a plane and it damaged my OSD pro!! So I ordered another osd pro from Graves rc.

I went to do the updates on the firmware. Everything on the data logger and the Guardian seems to be working right flashing lights and all.

But the new OSD pro module will not take the firmware update.

I update the Logger and even the Guardian successfully

It detects all three pieces logger, osd, and guardian

But when I go to flash the new firmware on the new OSD module I keep getting the error:

"A Firmware programming error has occured. Please disconnect device from usb, reconnect, and try again"

I know its not my usb connection because my computer recongizes the usb device it also does the firmware updates on the logger and the guardian properly.

All software is the most recent and has been reinstalled. I keep getting the same error.

Do I have a bad osd unit? Graves hobbies sent it to me in a box without any protection and with other things in the box. The bag that it came in with the wires and everything the sticker with the logo on it are kind of old and faded. Is this a bad unit or is there something I can do?

Thanks for your help!!!

Adam
whosthebaddest is offline Find More Posts by whosthebaddest
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 21, 2012, 04:04 PM
billpa's Avatar
Joined Nov 2003
4,906 Posts
Hi Adam,

When you connect the OSD Pro to the eLogger, and click "Hardware, Firmware Control" I'm assuming the OSD Pro shows up as connected? Also, are you running our latest release software, 10.04?
billpa is offline Find More Posts by billpa
Site Sponsor
Reply With Quote
Old Feb 21, 2012, 08:22 PM
Registered User
Joined Nov 2010
108 Posts
Yes thank you for your help Bill!!

I was successful in communicating with your technical support department through my ticket and I am sending my unit in for testing.
The technical support guy was excellent and very friendly. I am confident the problem will be resolved shortly. Thanks again for your help!!

Adam
whosthebaddest is offline Find More Posts by whosthebaddest
Reply With Quote
Old Feb 23, 2012, 01:17 PM
jcooksey
jcooksey's Avatar
west tn
Joined Feb 2010
197 Posts
What can I do to update my elogger V3? I recently got the postage stamp size guardian and tring to set it up.i have the horizontal line working but I couldn't find the stablization menu on my OSD. So I tried to updat the firmware and my computer doesn't recognize it. I downloaded the newest from the ET site and uninstalled and reinstalled. Still no luck.im running windows 7. And I've tried every USB source on my laptop. Also unplugged everything from the elogger and powered the elogger by the rc lipo . Still no luck... I purchased this elogger about 1 1/2 year ago
jcooksey is offline Find More Posts by jcooksey
Reply With Quote
Old Feb 23, 2012, 05:56 PM
Registered User
Joined Nov 2010
108 Posts
I believe that the only way to access the stabilization menu is through the actual osd output not on the computer you have to use the on screen menu not the software. If you look closely in your manual for the Stabilization I think it mentions that but not 100 percent sure. If you look through your goggles/monitor and access the osd using your RC transmitter/controller rather than throug the software. You will see there is a menu option on the screen. You can only do it through your rc controller/tranmitter way of accessing the menu I think

good luck

Adam
whosthebaddest is offline Find More Posts by whosthebaddest
Reply With Quote
Old Feb 23, 2012, 07:13 PM
jcooksey
jcooksey's Avatar
west tn
Joined Feb 2010
197 Posts
Thanks but this is the way I've been doing it( through the monitor not computer)I havnt been able to find it. Does anyone have a video showing how they get to it?
jcooksey is offline Find More Posts by jcooksey
Reply With Quote
Old Feb 23, 2012, 07:33 PM
Registered User
Joined Nov 2010
108 Posts
I'm not sure then on mine it just says Guardian or stabilization as a menu option on the main menu on the osd. You may want to contact the tech support on the phoen I found them to be helpful if you call mon wed or friday 1-4 PST is when they do tech support. I left a message and they called me back an hour later.
whosthebaddest is offline Find More Posts by whosthebaddest
Reply With Quote
Old Feb 23, 2012, 07:46 PM
jcooksey
jcooksey's Avatar
west tn
Joined Feb 2010
197 Posts
How do you update your firmware? Step by step plugging in your coputer.
jcooksey is offline Find More Posts by jcooksey
Reply With Quote
Old Feb 23, 2012, 08:01 PM
Registered User
Albuquerque, NM
Joined Sep 2006
50 Posts
Quote:
Originally Posted by jcooksey View Post
How do you update your firmware? Step by step plugging in your coputer.
1. Start Data Recorder.
2. Plug in eLogger via USB to laptop.
3. In Data Recorder, click Hardware, then Firmware Control.

I'm running the Alpha version of Data Recorder (v10.17), but shouldnt make a difference as I was able to update firmware using current stable (v10.04). I only updated to address the Google Earth output issue (search forum for more details).

HOWEVER....
Per documentation and web, it is stated to use the USB-to-mini-USB on eLogger (v4 only?), instead of the provided USB-to-pin cable. When I used the mini-USB on my Win 7 64bit laptop, I would get errors about the device not successfully installing. Tried several USB cables, and every USB port on the laptop. Even removed the related hidden devices in Device Manager... no luck. Thought my eLogger was trashed, but decided to try the USB-to-Pin cable... installed and worked perfect!

Side note...
It's best to open a new thread in the forum for your specific issue(s). However, for the issue you have been having, I would recommend giving ET Support a call.
MikeD096 is offline Find More Posts by MikeD096
Reply With Quote
Old Feb 23, 2012, 09:41 PM
jcooksey
jcooksey's Avatar
west tn
Joined Feb 2010
197 Posts
Got it. Had to plug into desk top. Thanks
jcooksey is offline Find More Posts by jcooksey
Reply With Quote
Old Mar 17, 2012, 05:26 AM
Registered User
Joined Mar 2011
1 Posts
Quote:
Originally Posted by MikeD096 View Post
1. Start Data Recorder.
2. Plug in eLogger via USB to laptop.
3. In Data Recorder, click Hardware, then Firmware Control.

I'm running the Alpha version of Data Recorder (v10.17), but shouldnt make a difference as I was able to update firmware using current stable (v10.04). I only updated to address the Google Earth output issue (search forum for more details).

HOWEVER....
Per documentation and web, it is stated to use the USB-to-mini-USB on eLogger (v4 only?), instead of the provided USB-to-pin cable. When I used the mini-USB on my Win 7 64bit laptop, I would get errors about the device not successfully installing. Tried several USB cables, and every USB port on the laptop. Even removed the related hidden devices in Device Manager... no luck. Thought my eLogger was trashed, but decided to try the USB-to-Pin cable... installed and worked perfect!

Side note...
It's best to open a new thread in the forum for your specific issue(s). However, for the issue you have been having, I would recommend giving ET Support a call.
I have the same problem.
What kind of USB-to-pin cable?
Can you write in more detail? If it is possible to some photos and how to connect?
evgenyl is offline Find More Posts by evgenyl
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion OSD Pro stopped working/causes Data Logger freezes sleziak Eagle Tree Systems 3 Jan 10, 2012 01:05 PM
Discussion Updating/flashing OSD Pro firmware without data logger, possible? sleziak Eagle Tree Systems 1 Jan 10, 2012 12:50 PM
Sold Eagle Tree Data Logger V3, OSD Pro, GPS Expander $150 bcucoach2 FPV Equipment (FS/W) 1 Dec 10, 2011 09:36 PM
Discussion OSD Pro Firmware update fail Mark taylor Eagle Tree Systems 11 Oct 18, 2011 02:31 PM
Help! OSD Pro firmware update problem avator1 Eagle Tree Systems 2 Jul 03, 2011 08:12 PM