HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Sep 18, 2011, 02:20 PM
Registered User
Joined Jul 2011
92 Posts
Discussion
Trim Adjustments? Drifting

If I am drifting backwards, what is the best fix?

Can I use the trim adjustments on my Tx?

Dan
df60532 is offline Find More Posts by df60532
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 18, 2011, 05:11 PM
S11D336B's Avatar
USA, FL, Winter Springs
Joined Apr 2006
3,066 Posts
Can you give us more information? Is it a slow drift? Is it a fast drift?

Are you using the spot board or the pro board?

In general, the best way to get rid of drift is to land and re-arm. You should never experience strong drift. Very small amounts of drift are normal.

Quote:
Originally Posted by df60532 View Post
If I am drifting backwards, what is the best fix?

Can I use the trim adjustments on my Tx?

Dan
S11D336B is offline Find More Posts by S11D336B
Site Sponsor
Reply With Quote
Old Sep 18, 2011, 06:42 PM
Registered User
Joined Jul 2011
92 Posts
Thanks.

Quote:

In general, the best way to get rid of drift is to land and re-arm.
I've done that, and it does seem to help.

If I arm my Y6 on a surface that isn't REALLY level, will it cause drifting?

I'll be posting a video very soon.

Dan
df60532 is offline Find More Posts by df60532
Reply With Quote
Old Sep 18, 2011, 07:07 PM
Pants first, then shoes
Joined Jan 2011
2,759 Posts
The bummer with having to rearm is that it shortens useable flight times. I go through a routine now where I start up my machine and power up my throttle till just below throttle and hold it at that power level for a while. After a short while, sometimes up to a minute I find the motors on one side will start to increase revs so my machine wants to start tipping. I then power down, disarm, disconnect the battery and start from the beginning again. Disarming for me doesn't seem to be enough. After I restart I usually can end up with a drift free flight although every now and then this still doesn't help.
I have this with both my green and black boards in my hexa, y6 and x8 setups. All three setups have had new motors and escs. The other symptom I see is it's alwas a drift towards about 11 o'clock. The only thing that i haven't yet tried is using a different radio but I have a new one coming this week.
I would love to be able to have this drift thing removed or even made a smaller level of drift. It's a problem if I'm wanting to do still photography because when it starts it's quite strong and to stay steady in the air I have to use continuous cyclic stick control.
The drift I have happening cant be removed with trims, its just too strong. thats with both green and black boards. Im still not sure if its a board issue or not. A new radio might help or if not it will mean I have eliminated another part of my builds.
Stacky is offline Find More Posts by Stacky
Last edited by Stacky; Sep 18, 2011 at 07:15 PM.
Reply With Quote
Old Sep 18, 2011, 07:13 PM
Registered User
Joined Jul 2011
92 Posts
Ok, here's my video.

Do I heard the HFP board beeping in flight, or is it something else? At 1:21 and at 1:48.

Feel free to laugh. You might as well .....

Y6 Maiden Flight Crash (2 min 16 sec)


Gain settings are wrong maybe? I had the auto level turned off.

I'm using the Airtronics RDS 8000.

Thanks,

Dan
df60532 is offline Find More Posts by df60532
Last edited by df60532; Sep 18, 2011 at 07:25 PM.
Reply With Quote
Old Sep 18, 2011, 07:24 PM
Registered User
tahoelight's Avatar
North Lake Tahoe
Joined Nov 2009
596 Posts
Looks like you need to adjust your gain. That wobble seems bad. Anyway. Are you trying to disarm and re-arm each landing? Does that help at all? Are you in AL or just normal mode? How does it look on your set-up utility screen. It is VERY important you make sure the multi-rotor is level when using the set-up utility and that your artificial horizon is showing level. Lastly, is the Center of Gravity of your setup good?

Just some thoughts.
tahoelight is offline Find More Posts by tahoelight
Reply With Quote
Old Sep 18, 2011, 07:39 PM
Registered User
Joined Jul 2011
92 Posts
Thanks.

With my Tx, my gain settings are in percentages. My gain channel is #5, and it's a 2 position toggle switch.

With the AL off, my gain is -25%. With it on, it's set at +50%.

I wasn't sure what it should be.

I'll double check my horizon on the computer too.

Thanks again.

Dan
df60532 is offline Find More Posts by df60532
Reply With Quote
Old Sep 18, 2011, 07:54 PM
Registered User
tahoelight's Avatar
North Lake Tahoe
Joined Nov 2009
596 Posts
The transmitter setting don't mean much. List what gain settings you are seeing in the setup utility. Report back after checking the set-up via the computer. Open your end point adjustments and make a chart showing what each end point adjustment will do to the main gain and AL gain. So then you can adjust it without the computer, but you can have the numbers on a sheet of paper that corresponds to a specific gain.
tahoelight is offline Find More Posts by tahoelight
Reply With Quote
Old Sep 18, 2011, 08:36 PM
Registered User
Joined Jul 2011
92 Posts
Will do tomorrow after work. What are the 2 settings on the computer that I should be aiming for?

thx
df60532 is offline Find More Posts by df60532
Reply With Quote
Old Sep 19, 2011, 12:29 AM
S11D336B's Avatar
USA, FL, Winter Springs
Joined Apr 2006
3,066 Posts
Looks like gain issue to me. Your gain is likely way too low.

To get your gain the same on both sides of your switch, try this.

Set BOTH sides of your gain channel's EPA to 100%

Then, using the setup client, adjust your subtrim for that channel until the same gain is read on both sides of the switch.

Now the EPA from one side is the same as the other side.

Quote:
Originally Posted by df60532 View Post
Ok, here's my video.

Do I heard the HFP board beeping in flight, or is it something else? At 1:21 and at 1:48.

Feel free to laugh. You might as well .....

http://www.vimeo.com/29235922

Gain settings are wrong maybe? I had the auto level turned off.

I'm using the Airtronics RDS 8000.

Thanks,

Dan
S11D336B is offline Find More Posts by S11D336B
Site Sponsor
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Blade CX3 Adjustments - drifting and trim bunger Coaxial Helicopters 92 Jan 28, 2011 05:37 PM
Discussion Any adjustments I can do to center up the trim on my CX2? crash331 Coaxial Helicopters 8 Jan 23, 2009 03:31 PM
Discussion trim and drifting issues Dadmann Micro Helis 1 Feb 09, 2008 12:19 PM
Discussion Trim Adjustments on TRex 450 mdavenport Mini Helis 6 Oct 14, 2007 10:07 PM
High Speed Trim Adjustments HILDY Foamies (Kits) 7 Aug 16, 2005 03:50 AM