HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 10, 2012, 10:01 PM
mmmmm
moocowfish's Avatar
Sydney, Australia
Joined Feb 2004
243 Posts
Help!
Bevrc 5.8ghz 200mw no signal

I bought the bevrc 5.8ghz 200mw plug and play withe the kx121 camera.

I powered it all up as the forums etc said, lipo 3 cell on Rx and small lipo 3 cell on tx, the monitor said no signal, I tested the monitor and it's ok, no I'm not sure whether it's the camera tx or rx.

Is there any way to test to see if the signal is working from the tx to the rx.

Thanks for any help, much appreciated.

Rob
moocowfish is offline Find More Posts by moocowfish
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 15, 2012, 03:24 PM
New Beeeeee
RUBNorris's Avatar
United States, CA, Sacramento
Joined Apr 2011
862 Posts
You fix it yet?
RUBNorris is offline Find More Posts by RUBNorris
Reply With Quote
Old Nov 16, 2012, 03:17 PM
mmmmm
moocowfish's Avatar
Sydney, Australia
Joined Feb 2004
243 Posts
No not yet, I've ordered a new camera, I think I must of burnt the other one out. It seems that on forums people are saying if you just plug the camera in the wires are the wrong way around?
moocowfish is offline Find More Posts by moocowfish
Reply With Quote
Old Nov 16, 2012, 03:49 PM
New Beeeeee
RUBNorris's Avatar
United States, CA, Sacramento
Joined Apr 2011
862 Posts
You can get away with swapping the wires around. an you take a picture?
RUBNorris is offline Find More Posts by RUBNorris
Reply With Quote
Old Nov 18, 2012, 09:51 PM
Thread Crapper
JohnVH's Avatar
Lynden, WA
Joined Nov 2000
2,611 Posts
I know my ground station won't show anything if the tx doesn't have a camera hooked to it. Mine is a hobbywireless
JohnVH is offline Find More Posts by JohnVH
Reply With Quote
Old Nov 18, 2012, 10:14 PM
mmmmm
moocowfish's Avatar
Sydney, Australia
Joined Feb 2004
243 Posts
thanks John, thats what im thinking, hopefully when the new camera arrives i will wire it up correctly and it will all be good.

thanks

Rob
moocowfish is offline Find More Posts by moocowfish
Reply With Quote
Old Nov 18, 2012, 10:42 PM
Thread Crapper
JohnVH's Avatar
Lynden, WA
Joined Nov 2000
2,611 Posts
Yeah. Keep us posted. Where did you order the camera from?
JohnVH is offline Find More Posts by JohnVH
Reply With Quote
Old Nov 27, 2012, 11:11 PM
mmmmm
moocowfish's Avatar
Sydney, Australia
Joined Feb 2004
243 Posts
So, got the new camera from Hobby king, changed over the pos and vid as marked on the camera circuit board. Wired it up to the transmitter and plugged it in, boom !

The transmitter shorted.....

Off to order a new one, starting to get sick of this.

This may be a lesson no to buy the cheap stuff.

Rob
moocowfish is offline Find More Posts by moocowfish
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold 5.8GHz 200mW Fox Tech Tx healthyfatboy FPV Equipment (FS/W) 2 Mar 12, 2012 02:03 PM
Sold Haier 7" LCD integrated 5.8ghz RX, 200mw VTX, Mini OSD, Camera, 11db Patch antenna crd FPV Equipment (FS/W) 4 Mar 11, 2012 11:58 AM
Discussion BevRC 5.8ghz 200mw RANGE TEST. kashalp FPV Talk 9 Sep 29, 2011 09:11 AM
Discussion bevrc 5.8g 200mw w/ gopro? kashalp FPV Talk 1 Sep 22, 2011 03:47 PM
Discussion Trouble with bevrc 5.8g 200mw dj.zig FPV Talk 21 Jan 21, 2011 08:16 AM