New Products Flash Sale
Thread Tools
Old May 14, 2015, 06:55 AM
cosmonaut1959 is offline
Find More Posts by cosmonaut1959
Registered User
Joined Aug 2014
77 Posts
Discussion
Dragonlink RX won't connect to computer

I can't get my PC to connect with my Dragonlink RX. I have tried everything I know but I can't get it to work. I see the RX in device manager under "other devices" but not on a com port. Does it have to be on a com port? If so how do I do it. I was thinking it could be a driver issue but I can't find just a driver that is an executable file. I am using the latest software from Dragonlink.
I am not sure which version RX I have. It's the generation before the current one. I have had it about 6 months. I have tried a Windows 8 PC and also a Windows 7. Any help appreciated.
cosmonaut1959 is offline Find More Posts by cosmonaut1959
Reply With Quote
Sign up now
to remove ads between posts


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion UDI U839 Remote Won't Connect jdpowerhouse Mini Multirotors 7 Jan 22, 2015 05:54 PM
Help! APM2.6 won't boot, MinimOSD: can't connect to bootloader BadBert Multirotor Electronics 0 Nov 04, 2014 02:31 AM
Question Multiwii 328p won't connect to computer Crixus Multirotor Electronics 1 Oct 23, 2014 05:24 PM
Discussion Transmitter/RX won't connect w.gullotta Scratchbuilt Multirotors 2 Aug 04, 2013 01:37 PM
Discussion Park Zone Fokker Dr.1 won't connect to rx rcnutt Scratchbuilt Indoor and Micro Models 16 Jan 23, 2013 06:36 AM