Shop our Airplanes Products Drone Products Sales
Thread Tools
Mar 14, 2014, 11:28 AM
Registered User

copy imax b6 usb TX problem

hello. i have buy an copy imax b6 from , 1 months ago. it works normally but i cant connect to pc. i buy an serial to usb converter , it is working and tried it with arduino.
i am connecting to converter and converting temp mode to usb mode but there is no transmit from charger. there is no info about micro controller unit.
i am looking to chip but it is blank. no info.
how i can fix this problem ?
Sign up now
to remove ads between posts
Mar 14, 2014, 11:36 AM
Registered User

photos with screen removed
Mar 14, 2014, 04:54 PM
Registered User
what type of forum this is ?
i am looking for help , nobody answers.
i need heep but nobody answers
Mar 14, 2014, 05:18 PM
Registered User
You have to give people time to answer. Be patient.

I'm afraid I do not understand what you are trying to do though. You bought a USB FTDI but I fail to see what you want to use it for. It will not program that chip. The chip is most likely a counterfeit of an Amtel AVR micro controller as that is what is most commonly used in this style charger.
Mar 14, 2014, 05:23 PM
Registered User
i want to get graphs , like logviewer.
but i cant get any signals from charger device
i have select usb mode.
temperature mode works good but usb not
i dont want to program anything
Mar 15, 2014, 03:41 AM
Registered User
rizky_p's Avatar
I don't thing imax b6 support any kind of Data logging.
Mar 15, 2014, 06:37 AM
Registered User
yep , i think so
i tried to tx pin from atmega 32 datasheet but i cant get signal again.
i think my copy doesnt support serial
Mar 17, 2014, 01:12 PM
Registered User
The data port is that 3-pin port on the left side. You need a cable/software like this:
Jul 05, 2015, 07:52 AM
Registered User
Did you ever get your charger talking to the arduino?? I'm having trouble with mine. I can read the serial data fine to the computer but the arduino is not recognising the serial data.

Quick Reply

Thread Tools