View Single Post
Old Jun 14, 2002, 07:21 PM
mike93 is offline
Find More Posts by mike93
Registered User
Santa Barbara/Roseville, California
Joined Dec 2001
310 Posts
PLEASE Help me with my zero throttle response on my radio!!! (Please read)

O.K., I have a conversion American Airlines plane that I am builing. 2x EDF-50 in parallel, worked before, now zero throttle respones.


Setup:

Bench Testing with ICS-50(Checked to see if it was toasted because of amp draw, not the problem, works on mini max with different radio)

Futaba 4channel Skysport Radio
T, E,R A:everything works except the throttle. I have zero response with the above radio, even after checking other crystals. I then tried Futaba radio in the mini max with the same ESC as above and again same response NO THROTTLE. Tried out my Hi-tec Focus III radio with same ESC in the mini max and it worked!! Then I tried one EDF-50 with Hitec 3 channel radio with same (ICS-50) ESC, and that worked perfect.
I then tested the Futaba Radio with the same ESC, in the same setup as the Focus III: No throttle response, but servo control is good. I had both motors working fine earlier, and then ran out of battery power, thought that I burned up the ESC, but it still works.

Is it possible to damage the radio in any way?? I tried another servo on the rudder/Throttle stick on the Futaba radio, and again no throttle, but rudder control worked.

I am running out of possibilities, please help me because I don't have to tools or the experience neccessary to figure this out on my own.


Thank you for your help,


Michael Arnoult
mike93 is offline Find More Posts by mike93
Reply With Quote