View Single Post
Old Aug 11, 2013, 04:39 AM
acc007 is offline
Find More Posts by acc007
Registered User
Poland
Joined Jul 2011
164 Posts
Hi guys,

while trying to check USB hardware on v1.2 board I've discovered one major fault on my board. And it's all because I was gathering components to be ready for v1.3ce2...

It's all about the crystal. 1.3ce2 BOM suggests digikey #887-1452-1-ND. Someone in the thread suggested digikey #535-9720-1-ND as an available replacement. I also got similar crystal for my boards. But... the thing is that these crystals are 4P - have 4 little squares to solder.

PCB v1.3ce2 is ready to accept them. PCB v1.2 is NOT - it's prepared for 2P crystal, having only 2 larger areas to solder. The whole thing is about the internal connection diagram for 4P crystal, have a look:

So... pins 2 and 4 are connected. PCB v1.2 has only 2 pads to solder, so in fact pin 1 connects to 4, pin 2 connects to 3, therefore everything is short-circuited. And - that makes crystal not working, there is always a short-circuit between crystal legs.

As a result - cpu fails to start up external crystal and runs internal 8Mhz oscillator only. Therefore - motor's PWM are not rated at 18kHz, but 2kHz only ! But they work "somehow" :-) And everything else works correctly as well (GUI, leds) Arrggh... that was really hard to find out, I wouldn't have done that without my logical state analyer, I was really surprised having 2kHz on my motors :/

So - you guys having assembled v1.2 board on your own and using the crystal with 4pads - better fix it. The easiest way to fix is to replace the crystal with the one having 2 pads. But - it's not required, it can be fixed. All you need is hot air gun (to desolder the crystal) and a bit of kapton tape.

First I tried to connect external crystal with cables:


and... it worked like a charm. So... all I need was putting some kapton tape on pads 2 and 4, exactly the same as in the second picture. Then I soldered my crystal back to v1.2 PCB and it is working now as it should

And at the end, one sweet thing to all of you. I've checked VCP (virtual com port via USB) with some loopback demo and it works on v1.2 hardware! So in the near future we should have USB support builtin

Ahh - and now I can really enjoy the motors silence at 18kHz, compared to 2kHz PWM
acc007 is offline Find More Posts by acc007