View Single Post
Old Jan 28, 2013, 04:07 AM
Isoprop is offline
Find More Posts by Isoprop
Registered User
Joined Nov 2010
2,865 Posts
Quote:
Originally Posted by citam View Post
Hi to all,

I have problem with my camera 808-11-HD-Lens-DVR-Car-Keychain..., it`s only red LED working and nothing else.

So, the cause for not working is the fact that the CAM was accidently forgotten in the pocket in one of my clothes and put into the washing machine... After being washed i took out of housing the PCB and dry it, and after that the CAM worked normaly. But not for long, after 3-4 days it has stop working, only red LED "on" when on USB...

Status:

- only red LED on when on USB(battery Charging status, when battery full - LED "off")
- when on USB, the device or SD storage not recognized by PC, nothing happens
- LiPo is normaly charging when conected on USB
- voltage seems normal on PCB, on USB(4.88V), uSD (3.30V), IC`s (1.8-3.30V)

History on what had been done so far:

- all kind of combinations for "start-up", "ON"..., "reset then ON",... etc
- uploaded firmware FW96630A.bin (bought new same camera and uploaded same firmware, and CAM is working normaly)
- bought "WINBOND W25Q16BVSSIG" eeprom and replace it with the procedure described on http://g--labs.blogspot.com/ site

I don`t have any idea anymore what else to try, so i kindly ask you to give some hint or solution, or maybe similar expirience because the CAM still not working...

Best regards,

Matic
I suspect some other component was not properly dried and has now shorted. I take it you programmed the SPI before replacing it? Dumb question, but just to be certain. I don't know your soldering skills, but I also take it you replaced the SPI in the correct orientation and didn't overheat it if using a hot air soldering station?

If the firmware was running, even partially, you should get some indication of life. The red LED is controlled by the charger IC so has nothing to do with the rest of the circuit. At least it shows that the charging IC is working.
What happens without the lens ribbon cable connected? Still nothing?
When you connect the camera to the PC, does it get briefly recognized. It should, even if all the circuitry isn't working properly.

So long the yellow LED doesn't even blink, I suspect a hardware failure or corrupted firmware (in the SPI). You can measure most of the resistor and capacitor values on the board, but a few you will have to desolder to check. You can also check the transistors for short circuits. And are you sure you programmed the SPI with a valid dump?

I haven't tried it, but there are also three RS232 solder points on the board. The TX might give you additional information, but only if the firmware is running.

There is also a slight possibility that the CMOS module/cable is defective. If you have a spare module it would be easy to check.
Isoprop is offline Find More Posts by Isoprop