View Single Post
Old Jan 24, 2013, 01:34 PM
bigjohn is offline
Find More Posts by bigjohn
dare to be dull
bigjohn's Avatar
Deland, FL
Joined Jun 2002
807 Posts
Discussion
Mach 3 (unlicensed) and Foamlinx 2912

I have been trying to get Mach 3 to run a Foamlinx 2912 for the past few evenings. I have run into a real snag that I don't have a fix for yet. I'm not an expert and am not very familiar with Mach3 yet.

The Foamlinx machine was bought 2nd hand. To prove it works, I loaded the NT control PC with Foamworks 3, since it is an all-in-one program. That allowed me to check out the parallel conection, the motors, etc. Everything worked once I sorted the bits out. I didn't actually try to cut foam though, just wanted proof that all the parts worked.

To get serious, since I am already a Profili user, I wanted to load Mach 3 and cut cores that way. I loaded Mach 3 and also incorporated the cool custom 4 axis control screen:

http://www.rcgroups.com/forums/showthread.php?t=1167734
I am using the X, Y, A, B axes in the software. The problem I am having is that the vertical axes do not change direction. If I give the up jog, they go up. If I command a down jog, they go up.

In order to troubleshoot, I deactivated the A & B axis and am just concentrating on figuring the problem out on the Y axis. Then I'll make changes to the B axis when I figure it out.

I have changed the Dir Low Active settings around without fixing this problem. I have completely remapped the jog keys a couple times to different keys to make sure there wass nothing wierd there.

Not sure what the problem is. I suspect that the pin that controlls direction, #5 for the Y axis is not active for some reason. I have set up the pin numbers per the foamlinx docs as far as I know. I notice that if you put a nonsense value in the dir pin box for one of the horizontal axes, it will behave the same way each time - one direction only, regardless of which key/arrow is pushed.

I think that would originate either because the software/driver is broken which could be:
- Bad install/corrupt driver or
- Some software setting i don't know about that needs to activate the dir pins or
- The card(s) controlling the vertical axes on the foamlix box is not responding to the dir command.


I think tonite, for troubleshooting, I will swap the dir and step pin numbers between the X and Y rows in the Mach3 Motor Output page, so the x-axis controls the vertical drive and the y-axis controls the horizontal drive on the foamlinx box. That way I will be able to tell if the software/PC side is not issuing the direction command or if the Foamlinx control box is not processing it.

If anyone has seen something similar, please chime in. Spending the evening troubleshooting instead of making stuff, stinks.
bigjohn is offline Find More Posts by bigjohn
Reply With Quote