Thread: Discussion MJX-F45 Single Rotor FP
View Single Post
Old Jan 20, 2013, 05:09 AM
R.C. Man is offline
Find More Posts by R.C. Man
Frank
Germany, BW, Heubach
Joined Dec 2012
928 Posts
Quote:
Originally Posted by tiggertoo1962 View Post
Hi guys

Big Bird II arrived yesterday just before I had to go to work. Only had enough time to find out that the charger doesn't work (email sent straight away) and that the heli made a "tsst, tsst, tsst" sound when running on the bench. Thought it might have been flybar strikes caused by slop in the blades, so I shimmed them without any noticable improvement. My thoughts then turned to unbalanced blades maybe having the same effect (strikes) but since I don't yet have fine scales I couldn't check it. Made a vid for analysis below. As can be seen, the flybar looks to be balanced and not hitting the blades.

http://www.youtube.com/watch?v=QPvD9...ature=youtu.be

Had a closer look this morning and discovered that the aile and elev servos have their own minds, and start twitching when the battery is plugged in. Happens even before binding with the TX. The noise I heard is obviously the servos twitching when the motor is running.

http://www.youtube.com/watch?v=eeG0t...ature=youtu.be

Is there an easy fix for this or do I need to send the heli back as a duffer?

Sorry about the vid quality... took it on my #808 so couldn't see what I was filming

Cheers
Fin
Wow Fin,
You got a problem child there,
Try moving the servo wires around, I had a problem something like that after rebuilding my 45 completely
my tail was moving on its own, and I just moved the wire routing, and was all ok again, maybe getting a frequence from the electronics on pcb.

Frank
R.C. Man is offline Find More Posts by R.C. Man
Reply With Quote