View Single Post
Old Jan 19, 2013, 10:27 PM
dankx is offline
Find More Posts by dankx
Registered User
Joined Jan 2013
11 Posts
Discussion
Dynamite Passport Ultralite HELP!

After plugging my balancing board (right underneath the light button), then i plug in my battery....well i can go check my voltage and it will show my voltage but will NOT start the charge process or anything really except showing voltage.....After holding down enter for 3 seconds (the first step), it says problem with main server port..... So why?(everything is snug) Afterwards, i tried the adapter i got from my LHS that has every adapter imaginable, it has the big black connector type that is on my battery just the same as where i plug it into the car itself..... I used the banana plugs to plug into my charger, and then used that adapter and plugged my battery into it like i would if i plugged it in my car, that worked and allowed me to start a charge but wouldnt show voltage (my voltage led wont work just on the screen in a certain menu when it does....), also after started it a 5.0 amp speed, it started dropping fast and stayed at 2.0 then went down to 0.3 then stopped after like 40 mins -_-, why would it just drop from 5.0...then it acted like it was done when it was only at 2000 mAh (buzzer didnt go off) but it said end (was blinking..)

PLEASE HELP i wanna drive my slash !!!!!!! Im SOOO frustrated.
dankx is offline Find More Posts by dankx
Reply With Quote