Thread: Discussion Eclipse 7 and servo centering
View Single Post
Old Jan 10, 2013, 05:03 PM
A.T. is offline
Find More Posts by A.T.
Registered User
Joined Aug 2002
5,811 Posts
Quote:
Originally Posted by Scarlet View Post
Hi. I just noticed that,in heli mode, the servos center in different positions from normal swash
when 120deg swash is selected. Is this normal?
I have a ccpm servo centering device too,and when centering the servos using this device the centering is the same as the normal swash setting.Thanks.
The difference is not mentioned.
If only minor, would not be concerned as this could be in the mix.
If it is a feature in all Eclipse, (not noticed in mine with simple bench setup) it is really of no consequence
because user selects "Heli" and then the type "NOR", "120'" or "180" must be selected before
the remainder of the model detail is entered.
(Eclipse 7 - 90 degree CCPM Setup)
If changing swash setup at any time, then that model number must be reset,"REST", to clear
all extraneous data before reloading with different swash setup.

Many Hitec servo arms are not at 90 degrees when placed on the output shaft of a servo that
is "centered" with zeroed trims because of the spline count.
Servo horn is then centered by using sub trim which must be done once only
at the start of model set up before any mixes or other major changes.

If there is a major change observed and continuing concern, suggest email direct to:
Hitec Warranty & Service - homepage.
Note: Hitec USA only services North/South America and Canada.
"Hitec USA customer service department is available Monday through Friday*
from 7am- 4:30 pm Pacific time. Reach us at 858.748.8440 or
service@hitecrcd.com any time you have a question"
If you are from a country that is outside North and South America, please contact the
Hitec distributor in your country for service.


Alan T.
Alan's Hobby, Model & RC FAQ Web Links
A.T. is offline Find More Posts by A.T.
Reply With Quote