Thread: Discussion Walk-era and Beyond
View Single Post
Old Dec 10, 2012, 02:35 PM
kdean is offline
Find More Posts by kdean
BahamaHeli
kdean's Avatar
The Bahamas
Joined Dec 2010
3,835 Posts
I have not tried to fix the tracking problem yet, i droped a post on the 500gt thread to see if anyone over there has seen this type of problen before. Im wishing it would be the dampers, but the only thing i changed was the blades before the problem showed up. I would hate to have to throw away a new set of blades. Yeah they are the cheap fg ones that come with the hk kits, but its still a new set of blades. I could never have too many spare blade sets...

I took the 450pro out for more testing today. I made some adjustments to the gov setting, now getting 3100rpm in IU2, and found that the grub screw in the tail blade grips was loose. That was why the tail would not lock for those first few flights. I also did a complete re-setup of the beastX. The first flight was going great. It was 10-15 constant wind so i did not get to wild. But after two piros, and going for a third in the other direction, i lost all tail control and it was going into the 'spin of doom'. If this had happend to me a year ago, i would have not been able to save it, but today i made myself proud of my emergency landing skills. It was about 15 to 20 feet up, and when it started its out of control spin I hit the throttle hold right away and was able to bring it down safely on its skids. Did not even strip a tt gear. I was able to load up that grub screw with loc tite, and it was flying again right away.

I'm happy the 450pro is getting back in the game. Its feeling really solid with the extra weight and the beastx. At one point i was thinking of getting away from the 450 size but today got me interested again.

I also did a complete reset of the 500bx, but time ran out on my lunch break. Maybe tomorrow...
kdean is offline Find More Posts by kdean
Reply With Quote