View Single Post
Old Nov 17, 2012, 03:02 PM
1Hammer is online now
Find More Posts by 1Hammer
Micro Helicopter Electrician
1Hammer's Avatar
Central California Coast
Joined May 2008
2,930 Posts
Quote:
Originally Posted by Hajile View Post
I got impatient waiting for the parts from eHirobo so i went over to the local hobby shop (yes, the same guys i bought the 450parts that didn't fit) and bought a tail motor from them. The thing about it tho is that the tail blade was split in two so they game me another tail blade. I did wonder what kind of force it had been subjected to have a tail blade break.

So i changed the tail section, plugged in the batteries, and powered it up. The heli started spinning uncontrollably, it seems the tail motor wasn't spinning. So powered it down while i tried to figure out what was going on.

Then all of a sudden thick smoke started coming out of the canopy and it was lighting up. The thing actually caught fire!



Aw come on!!! Seriously??? Can anybody explain what happened? What was the part that burned up???
Sounds from your description and looks from the photo as though the tail motor had a direct short in it that fried the FET on the PCB.

Impatience can be expensive...learn from your mistakes. I paid a lot for my formal education, but my informal education (life) has cost me some but I've learned much more in a practical way from the informal side of the equation.

Looks like it's time for a new RX for your Genius.

Regards,
John
1Hammer is online now Find More Posts by 1Hammer
Reply With Quote