Thread: Discussion Tired of DLE 20cc
View Single Post
Old Nov 13, 2012, 12:33 PM
BrianSmith is offline
Find More Posts by BrianSmith
<>< AKA W4BPS
USA, TN, Tullahoma
Joined Dec 2001
2,428 Posts
ignition box

The reason the idle seems to hunt. Just an idea................It is the set timing in the ignition box. It has a step. Once it sets at idle for a bit it will slow down even further like about two clicks on the throttle trim. Then That is as low as it will go, but once you throttle up it will idle fast again till you let it idle for 20 or 30 seconds. The only fix I can find on mine is to exchange the ignition box for a new stock Rcexel ignition box, or get used to it now that you know what is up.. Brian



Quote:
Originally Posted by mnavarro View Post
I'm sure many of you have had success with the DLE 20cc, but I'm officially tired of this DLE. This is a motor that has < 2 gallons on it. The motor just doesn't want to run at idle when warm. When warm it will not run unless using electric starter and full throttle. Sometimes seems ok. I have inline fuel filters. Idle seems to hunt. The person who help me tune it sets up the DLE 55 with no problem. Seems the carb is the problem.

My options are return to vendor to have it serviced where they will likely replace carb, with the same garbage.

Buy a "walbro" carb that's supposed to be japanese but is shipped from china and perhaps is no different from the dle knockoff. Does anybody know that the walbro carb on the DLE 20cc make it run better or is better quality.

I'm kind of tempted to look at the OS GT22 but there's very little info on this motor. Anybody can get 80 off the os gt22 @towerhobbies. I would gladly pay more for the reliability of the DLE 55 in a 20 size at this point.
BrianSmith is offline Find More Posts by BrianSmith
Last edited by BrianSmith; Nov 13, 2012 at 02:39 PM.
Reply With Quote