Thread: Discussion New: Multiplex Acro Master
View Single Post
Old Nov 11, 2012, 08:57 PM
Watdazit is offline
Find More Posts by Watdazit
A geriatric flier
Watdazit's Avatar
Australia, NSW, Braidwood
Joined Nov 2008
1,239 Posts
I think I have the vibration licked. I fitted the metal plate and in doing this I set the thrust angle bolts to the recommended distances. After I had gorilla'd the bolts holding the plate I noted some of the adjusting bolts were still loose. I could screw them in and out without any tension on them and not affecting the angle of the plate. I backed the main bolts holding the plate out a fraction and then tightened the adjusting bolts until i could just feel a little resistance. I then tightened the main bolts again. I did a test run up to full throttle....I wince whenever I do this....and hey presto...no vibration.

A note of caution. The thrust angle may not be correct now so it will be a case of fly and try.

I have always had some reservation about the two bolt fixing of the plate. If any of the adjusting bolts are not hard onto the plastic surface of the side pieces the plate could wobble under load. This what I think is happening and causing the vibration.

Perhaps if you try the plastic plate and make sure the adjusting bolts are touching before you fully tighten the main bolts you may be OK. Let us know how you go.

PS You will find the thrust adjusting bolts into the plastic are quite tight and it may be difficult to tell if they have grounded. Suck it and see.
Watdazit is offline Find More Posts by Watdazit
Last edited by Watdazit; Nov 11, 2012 at 09:00 PM. Reason: PS added
Reply With Quote