View Single Post
Old Nov 06, 2012, 12:26 PM
happyusers is offline
Find More Posts by happyusers
Registered User
Paris
Joined Dec 2010
175 Posts
connecting a FMP04 gps

I have bought a FMP04 GPS some time ago and ordered a GPS bob from Flyduino. I soldered all that together and let it rest for a while. Recently I ran upon it and decided to give a try. I wired the bob to an Arduino NANO and tried to read what came out of GPS.
The wiring was simple :
GPS Tx ---> Nano D2
GPS Vcc ---> 5V
GSP Gnd ---> Nano Gnd

The programm was even simpler, it merely gets what is present on softserial and put it on the hardware serial port :
Code:
#include <NewSoftSerial.h>

NewSoftSerial GPS(2, 3);

void setup()  
{
  Serial.begin(57600);
  Serial.println("Goodnight moon!");

  // set the data rate for the SoftwareSerial port
  GPS.begin(2400);
//  mySerial.println("Hello, world?");
}

void loop() // run over and over
{
  if (GPS.available())  Serial.print( GPS.read(),BYTE);
}
So far I did not succed but here is what I noticed :
the GPS seems to product data. On the arduino serial monitor, I get garbage but when I disconnect the Tx wire, there is no more data. I have tried various baud rates from 2400 to 115200 but I get always unreadable char.
Probably I made an error somewhere but I am not able to go any further.
Next try would be to connect the GPS to a PC serial port. Could you give me an advice? Would you have other ideas in order to test that piece of electronics? Is there some sort of arduino programm that could analyse what go out of GPS? Let me know, I shall be gratefull. Thanks.
At last I read somewhere on that forum that it is possible to update the firmware of certain GPS units. Would it be the case for mine and could it be the solution?
happyusers is offline Find More Posts by happyusers
Last edited by happyusers; Nov 06, 2012 at 03:34 PM.
Reply With Quote