Thread: Discussion New Eclipse 2.4 PRO?
View Single Post
Old Nov 04, 2012, 12:02 PM
A.T. is offline
Find More Posts by A.T.
Registered User
Joined Aug 2002
5,811 Posts
Eclipse 7 & Eclipse 7 Pro - Simulator Interface Cable & Wireless Simulator Interface

Quote:
Originally Posted by Backyard View Post
I have decided to get a Pheonix Simulator. Much of what I have read says it is not compatible with my new Eclipse 7 Pro. What do I need to make it work? What do I need to make it wireless?
Eclipse 7 & Eclipse 7 Pro Simulator function & Setup - Set-up
Headed "Aurora 9", section 4 and all those below apply to Eclipse, Optic and other Hitec Transmitters
as apart from the touch screen and minor changes, the cables and set up are similar.
Also attached are good instructional .pdf e.g. "Hitec TX _Setup Clearview, FMS & RC DeskPilot.
extract from Setup page:
4. Do Not try running any type of transmitter off a wall charger, whilst using a simulator,
this as charger outputs half wave rectified, unregulated and unfiltered DC.
Transmitter cannot function correctly on other than a smooth fully regulated
battery type power source.
(Reason why transmitter charger jack is shut off when Eclipse 7 is turned on.
User will notice that if transmitter is turned on whilst charger is connected, the LED
on the charger goes out to indicate it is no longer charging,
unfortunately this is not automatic with a 7 Pro)
1. Eclipse 7 insert 6 pin DIN plug into Trainer socket and turn on transmittter.
2. Eclipse 7 Pro Insert Mono jackplug into the Trainer socket, do not turn on Tx.
Plug powers required circuitry only, not inbuilt module.
The Hitec Simulator Interface Plug is wired so as to prevent RF section powering up, thus providing
greatly extended battery life.

With regard to Phoenix Sim:
"Much of what I have read says it is not compatible with my new Eclipse 7 Pro" in which forums? not on RCG Simulator forum.
extracts from above link:

1. "d). Phoenix
Plug in supplied proprietary USB cable (stereo plug in this instance) switch on TX & select "T-pupil" as above.
. Channel Mapping & Startup for Aurora and Simulators.
. Heli setup Q&A Post #3 this thread and
...Q. Phoenix 2.5 Heli flyer Able to go into idle up (on the sim) on the keyboard and none of the switches seem to map to any of the commands.
...A. Create a model in your TX. Set it up for a 90 deg swash one servo then go in and set your throttle and pitch curves for your conditions
ie normal, idle one, idle 2 etc...

..Phoenix Sim setup for 3D/scale (Heli or Plane) complete with zip file to download & install direct to an Aurora using HPP-22..

2. K). SimStick
. How To Set up JR/Spectrum plug type SimStick with A9 - Pictorial.

-------------------------

16Nov12 added post #38 below, expanding upon "Phoenix" sim.:
"If Normal setting does not work, see attached, try setting an E7 / E7 Pro model up
as an Acro which disables all Heli settings.
. Select a new model
. Enter main menu, select "REST" < depress both data buttons together, this to clear any extraneous data.
. Still in main menu, check that model number is set to "Acro" & "PPM", rename model as "Phoen" or "Sim" etc.

By not using any the mixes in the Transmitter, user can fly all the Acro & Heli in Phoenix Simulator with
same model - the different setups are applied within the Phoenix setup window:
.. Click System/ < Your Controls < click on the profile to be configured & click Configure Profile button.
.. All live values from transmitter being input will be showing.
. . Look for the invert column, click Engine and Collective Pitch in that column to reverse the channels in need.
Then use the Phoenix on screen set up for heli functions, as in post #35 above:
" . Heli setup Q&A Post #3 this thread"


Eclipse 7 & 7 Pro - Wireless Connection for Simulator Interface:
One known after market system is the Modelguard "Simstream".
Set up Eclipse 7 Pro in similar manner as pictured link "2. K)". above.

Further information is available under:
. Hitec Eclipse 7 & Eclipse 7 Pro - All Manuals, Addenda, Quick Setup, CCPM & Additional Programming FAQ
and sub Section
"Buddy Boxes, Flight Simulator & Interface." at:
. Alan's Hobby, Model & RC FAQ Web Links (quick search = Ctrl+F)
16 Nov 2012 added:
Quote:
Originally Posted by A.T. View Post
If Normal setting does not work, see attached, try setting an E7 / E7 Pro model up
as an Acro which disables all Heli settings.
. Select a new model
. Enter main menu, select "REST" < depress both data buttons together, this to clear any extraneous data.
. Still in main menu, check that model number is set to "Acro" & "PPM", rename model as "Phoen" or "Sim" etc.

By not using any the mixes in the Transmitter, user can fly all the Acro & Heli in Phoenix Simulator with
same model - the different setups are applied within the Phoenix setup window:
.. Click System/ < Your Controls < click on the profile to be configured & click Configure Profile button.
.. All live values from transmitter being input will be showing.
. . Look for the invert column, click Engine and Collective Pitch in that column to reverse the channels in need.
Then use the Phoenix on screen set up for heli functions, as in post #35 above:
" . Heli setup Q&A Post #3 this thread"

Alan T.

Alan T.
A.T. is offline Find More Posts by A.T.
Last edited by A.T.; Jun 30, 2013 at 07:03 PM.
Reply With Quote