View Single Post
Old Oct 25, 2012, 11:21 AM
Truglodite is offline
Find More Posts by Truglodite
Registered Aircraft Offender
Truglodite's Avatar
Carmichael, CA
Joined Feb 2007
3,546 Posts
carnisser, I feel your pain. I had the exact same problem with my DLv2... random and very discouraging failsafes. I spent weeks running the gamut of troubleshooting procedures. I really wanted to blame DL, but my perfectionist side kept me busy perfecting wiring until I had no more doubts; with perfect wiring on my quad, I could send DL back with confidence knowing they won't send it back saying, "nothing's wrong with it". I guess there's nothing wrong with that... maybe my ego is too fragile. Filters, shielded cable, ground loop removal... I went overkill big time... and guess what turned out to be the cause? A crash dented ESC capacitor!!! Seriously!?

Moral of the story is... an average FPV rig has 100's failure points. It sounds like you already know that and have done due diligence. I'm just saying... I know I did my homework, and I'm not an idiot... stuff like that can happen to the best of us. The cool part is knowing Mike is on your side when it comes to battling these complicated FPV problems... he offered to send me a whole replacement system just to be sure DL wasn't my problem.

Kev

Quote:
Originally Posted by tom3holer View Post
...I thought perhaps in doing the upgrade both of my Rx's received th 12Ch S/W upgrade by mistake but I have no way of telling?

Thanks,

Tom
If it were me, I'd plug in to ch12 and see if PPM is coming from there instead. IIRC, the latest firmware does put PPM on 12 instead of 9.
Truglodite is offline Find More Posts by Truglodite
Reply With Quote