Thread: New Product Nine Eagles Sky Surfer.
View Single Post
Old Oct 13, 2012, 07:00 PM
supermoth is offline
Find More Posts by supermoth
Registered User
Joined May 2012
131 Posts
Back to the prop issue.

Hi.
Finally after almost 3 weeks without flying we maiden my second S.Surfer(first one took of for ever,lost into the wind ). Actually we were a party of two.I did introduce the S.Surfer to one of my mates and he did purchase another unit.
Added to that we were testing the endurance with the new zippy's I got from HK.
My maiden was great and the endurance compared to the stock battery amazing.To be honest I don't abuse power on the S.Surfer.I just launch it with power to gain altitude and to glide.After several tests I was happy with the performance.We did apply the CA fixing to the wing servo as per the forum instructions and It did work great,one pain less to take care of.
The second maiden was another story.We found out that the prop was loose,so we did apply CA to it.One drop in the shaft,the other on the prop itself,but it did not work.As soon as we did apply power the prop flew away.Finally we decided to apply CA again but letting each side to cure for 5 min.This time it did work and we maiden my buddy's Surfer.It was great for almost 30 min,that the prop decided to take another excursion and was lost in flight.While we tried to recover it,the mission was unsucessful and had to stop flying.

So,I need your help and expertise to find out the best method to put back the prop in the shaft.It happens that lucky enough there is a spare prop with us and we can fix it,but this time we need to do it right.
By the way we were using Revell CA.I bought also some Multiplex elapor CA.Is it ok to fix the prop with it? What is the best method.?
Thanks in advance.
Have a great weekend.

S.M
supermoth is offline Find More Posts by supermoth
Reply With Quote