View Single Post
Old Oct 11, 2012, 09:52 AM
Matt Halton is offline
Find More Posts by Matt Halton
Wannabe B-26 pilot!
Matt Halton's Avatar
Southwold, Suffolk, UK.
Joined Nov 2002
5,059 Posts
Quote:
Originally Posted by Del-Dredd View Post
Try switching M1 and M2 connections on the board over, see if problem moves to M2.

If moves to M2 it is probably ESC, if stays on M1 it is something to do with KK2.

If there are standard unflashed ESC's, have you programmed them all the same using a program card or the Tx, ensure they all set same ie brake off, NiMh battery, normal start, low cut off, High timing. etc

They normally come with default programming but not always, I had one that was not using supposed default but i always program individually prior to use with relevant card programmer (multiple beeps using Tx and Rx just gets confusing).
Thanks Del and Fred for your inputs, appreciated. I calibrated them again (all three ESC's together) with the two button method from the board. Swapped over M1 and M2, but bizzarely the same motor (M1) is still not revving up or down when moving the frame in the rolling axis.
So, I tried a V 1.2 reflash, again no change.
Next step, get my first board out again, just to be sure, reflashed the board, v 1.2 again, set to tricopter mode, successful ESC and sensor calibration, but again, the same problems! When running from both boards, the same problem, but both boards, when manually applying aileron deflections with the stick, aileron works as it should (both M1 & M2 throttle up and down as they should..)

Running out of ideas now, can't surely be both boards, but if it is a dodgy ESC, then how does this happen

Ideas please?

Matt

EDIT: I kept the stock PI etc values after flashing both boards, as I figured there can be no mistake. Just completely lost on this now..
Matt Halton is offline Find More Posts by Matt Halton
Last edited by Matt Halton; Oct 11, 2012 at 10:00 AM.
Reply With Quote