Thread: Discussion MJX-F45 Single Rotor FP
View Single Post
Old Oct 11, 2012, 03:34 AM
Stoersender is offline
Find More Posts by Stoersender
Registered User
Germany, BW, Göppingen
Joined Aug 2012
70 Posts
Quote:
Originally Posted by Tumppi T View Post
Hi,

It's the smaller one close to the tail-motor plug (installed horisontal). I don't understand either why it doesn't work with the original FET, but i fried accidentaly the original FET......replaced it with the DH9104:s FET...and now its running

The FET is: CEP73A3G

It was very easy to install. Just cut the original FET:s connectors and then solder the FET away (It's soldered to the board from it's back). Solder 2 cm wires to the original FETs connection points (2) and one 2cm wire to the area where the original FET was fixed to the board. Solder two wires to the new FET in same order as the original. The third wire goes to the center connector. Then put some sticky tape behind the new FET and attach it in some good place. I put mine just onto the main circuit
Is it the first or the second one in the photo?



Just now I unsoldered number 1, but there was no third connection
And the left little connector came off... now nothing is working anymore, even when I soldered everything back together.... umpffff... I know why I don't like that complicated electronic stuff
so for now I think I'll need a new PCB board... or how can I attach the left connector to the board again?
Stoersender is offline Find More Posts by Stoersender
Last edited by Stoersender; Oct 11, 2012 at 04:58 AM.
Reply With Quote