View Single Post
Old Oct 08, 2012, 11:58 PM
flatlandrobin is offline
Find More Posts by flatlandrobin
Registered User
flatlandrobin's Avatar
New Zealand, Otago, Queenstown
Joined Sep 2012
79 Posts
Quote:
Originally Posted by ColSonders View Post
It looks like the ESC is knackered then.

I'd suggest that it's an issue with the electronics on the quad itself if the issue follows the ESC channel for a specific motor.

I don't see how it could be anything else given the tests done.

Swapping channels on the RX eliminates the RX as the same behaviour still occurs.

Multiple TX including none computerised radio eliminates the radio.

At this stage the issue has been narrowed down to the Quad itself.

Switching motors on ESC has shown the motors to be fine.

This leaves either the ESC board has an issue or as someone else stated earlier it could be the Flight Controller board having an issue with the balancing and compensating not calculating correctly.

I'd be asking the manufacturer for a replacement ESC board if it's in warranty.

Hey thanks for that comment, I feel the problem has been narrowed right down to only a couple of possibilities as well and Im glad that my efforts to prove it have not been in vain!

Its just not very nice for us noobs that dont have an electrical engineering degree to buy something ready-to-fly and then have to spend all this time taking them apart when we should be out there letting gravity do it for us!
flatlandrobin is offline Find More Posts by flatlandrobin
Reply With Quote