Thread: Discussion SKY 706 firmware upgrade
View Single Post
Old Sep 15, 2012, 12:49 AM
Parkflying is offline
Find More Posts by Parkflying
United States, MI, Auburn Hills
Joined Dec 2008
1,085 Posts
Quote:
Originally Posted by mperaltaoz View Post
Thanks for your reply.
I managed to fix it now by installing the original firmware again.
Here is a summary of the problem and it's solution.

Problem
The SKY706 application crashed whilst trying to update the firmware from SKY706 to SKY706V.
After that, the TX stopped working. It would link to the application and bind to the RX, but the sticks didn't send any signals to the RX or to the computer simulator through the cable.
Tried the firmware upgrade several times again, but it didn't work either.

Solution
In the application included in the CD that comes with the plane (Folder SKY706_V1), there is a folder named "siuse".
Within that folder there is another folder named "Upgrade", and inside this folder another one named "DeviceFile".
There you can find a file named "SKY706 D5-S1.res~vdrc".
I renamed that file to match the extension of the firmware files, i.e. to "SKY706 D5-S1.vdrc".
Then, I used the SKY706_V1.exe application to upload that file as the firmware to upgrade the TX.
It worked in this case, and the TX was fixed.
After that, I tried running the firmware upgrade again (to upgrade to SKY706V) and this time it worked.
yes this is the correct method to restore the firmware.
The upgrade normally proceeds correctly, but sometimes the computer program can lockup or fail, causing the update to fail.

Good news that you are now back to operating condition

Regards

Max
www.parkrcmodels.com
www.skyartec-usa.com
Parkflying is offline Find More Posts by Parkflying
Site Sponsor
Reply With Quote